# CVE-2026-57125: PraisonAI: Unauthenticated RCE via Jobs API + Approval Bypass

> Remote attackers can execute arbitrary OS commands via the Jobs API by bypassing approval checks in PraisonAI libraries.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Sep 2026
- **Updated:** 14 Sep 2026
- **Also known as:** GHSA-4869-x4pr-q22x, PYSEC-2026-3501, PYSEC-2026-3529

## What is CVE-2026-57125?

CVE-2026-57125 is a critical command injection vulnerability in MervinPraison PraisonAI, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PraisonAI is a multi-agent teams system. Prior to praisonai 4.6.59 and praisonaiagents 1.6.59, the unauthenticated POST /api/v1/runs Jobs API accepts attacker-controlled agent_yaml, and the approve field can mark execute_command as YAML-approved before @require_approval checks critical tools. This chain allows a remote caller to cause a configured language model agent to invoke arbitrary operating-system commands without credentials or operator interaction. This vulnerability is fixed in praisonai 4.6.59 and praisonaiagents 1.6.59 as fixed versions.

Weakness: CWE-863 (Incorrect Authorization), CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2026-57125?

6 open source packages ship an affected version, including praisonai and praisonaiagents.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai` | PyPI | All versions | 4.6.59 |
| `praisonai` | PyPI | All versions | 4.6.59 |
| `praisonai` | PyPI | All versions | 4.6.59 |
| `praisonaiagents` | PyPI | All versions | 1.6.59 |
| `praisonaiagents` | PyPI | All versions | 1.6.59 |
| `praisonaiagents` | PyPI | All versions | 1.6.59 |

## How do I fix CVE-2026-57125?

Upgrade praisonai to 4.6.59 or later.

## Is CVE-2026-57125 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57125 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57125 and fix it if it is affected.

What it is: CVE-2026-57125 is a critical command injection vulnerability in MervinPraison PraisonAI, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57125 exists.

Affected packages and fixed versions:
- praisonai (PyPI): affected all versions; fixed in 4.6.59
- praisonai (PyPI): affected all versions; fixed in 4.6.59
- praisonai (PyPI): affected all versions; fixed in 4.6.59
- praisonaiagents (PyPI): affected all versions; fixed in 1.6.59
- praisonaiagents (PyPI): affected all versions; fixed in 1.6.59
- praisonaiagents (PyPI): affected all versions; fixed in 1.6.59

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57125/ (Markdown: https://insights.sbomify.com/CVE-2026-57125/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57125
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57125
- OSV: https://osv.dev/vulnerability/CVE-2026-57125

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57125/
Summaries are generated and may contain mistakes; the official description above is the record.
