# CVE-2026-57128: PraisonAI: Unauthenticated Event Injection via SSE `/publish` Endpoint

> Unauthenticated attackers can inject events and read server configuration via the SSE publish endpoint in PraisonAI.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Sep 2026
- **Updated:** 14 Sep 2026
- **Also known as:** GHSA-35w5-pcw4-jx94, PYSEC-2026-3528

## What is CVE-2026-57128?

CVE-2026-57128 is a medium-severity missing authorization vulnerability in MervinPraison PraisonAI, published on 14 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

PraisonAI is a multi-agent teams system. Prior to praisonaiagents 1.6.58, the SSE server in src/praisonai-agents/praisonaiagents/server/server.py does not consult ServerConfig.auth_token before handling /publish, /events, or /info requests. A network client that can reach the server can broadcast arbitrary events to connected clients and obtain server configuration and client-count information. This issue is fixed in praisonaiagents 1.6.58.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2026-57128?

3 open source packages ship an affected version, including praisonaiagents.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonaiagents` | PyPI | All versions | 1.6.59 |
| `praisonaiagents` | PyPI | All versions | 1.6.59 |
| `praisonaiagents` | PyPI | All versions | 1.6.59 |

## How do I fix CVE-2026-57128?

Upgrade praisonaiagents to 1.6.59 or later.

## Is CVE-2026-57128 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57128 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57128 and fix it if it is affected.

What it is: CVE-2026-57128 is a medium-severity missing authorization vulnerability in MervinPraison PraisonAI, published on 14 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57128 exists.

Affected packages and fixed versions:
- praisonaiagents (PyPI): affected all versions; fixed in 1.6.59
- praisonaiagents (PyPI): affected all versions; fixed in 1.6.59
- praisonaiagents (PyPI): affected all versions; fixed in 1.6.59

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57128/ (Markdown: https://insights.sbomify.com/CVE-2026-57128/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57128
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57128
- OSV: https://osv.dev/vulnerability/CVE-2026-57128

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57128/
Summaries are generated and may contain mistakes; the official description above is the record.
