# CVE-2026-57129: PraisonAI: Arbitrary File Read via `@file:` Mention Path Traversal

> Attackers can read arbitrary files on the server by exploiting path traversal in file mention parsing, exposing sensitive data like credentials and configuration.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Sep 2026
- **Updated:** 14 Sep 2026
- **Also known as:** GHSA-2rcg-mm5h-xchx, PYSEC-2026-3527

## What is CVE-2026-57129?

CVE-2026-57129 is a high-severity path traversal vulnerability in MervinPraison praisonaiagents, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PraisonAI is a multi-agent teams system. Prior to praisonaiagents 1.6.59, MentionsParser._process_file_mention accepts file-mention values and falls back from workspace-relative resolution to Path(file_path) without traversal, symlink, or workspace-boundary validation. Prompt input from users, bots, or workflows can therefore read arbitrary files accessible to the process, including credentials, keys, environment files, source code, and system configuration. This issue is fixed in praisonaiagents 1.6.59.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-57129?

3 open source packages ship an affected version, including praisonaiagents.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonaiagents` | PyPI | All versions | 1.6.59 |
| `praisonaiagents` | PyPI | All versions | 1.6.59 |
| `praisonaiagents` | PyPI | All versions | 1.6.59 |

## How do I fix CVE-2026-57129?

Upgrade praisonaiagents to 1.6.59 or later.

## Is CVE-2026-57129 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57129 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57129 and fix it if it is affected.

What it is: CVE-2026-57129 is a high-severity path traversal vulnerability in MervinPraison praisonaiagents, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57129 exists.

Affected packages and fixed versions:
- praisonaiagents (PyPI): affected all versions; fixed in 1.6.59
- praisonaiagents (PyPI): affected all versions; fixed in 1.6.59
- praisonaiagents (PyPI): affected all versions; fixed in 1.6.59

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57129/ (Markdown: https://insights.sbomify.com/CVE-2026-57129/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57129
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57129
- OSV: https://osv.dev/vulnerability/CVE-2026-57129

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57129/
Summaries are generated and may contain mistakes; the official description above is the record.
