# CVE-2026-57130: PraisonAI: IMAP Command Injection via Unsanitized Email Search Parameters

> Attackers can inject IMAP commands via unsanitized email search parameters in PraisonAI, leading to mailbox data access, modification, or deletion.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Sep 2026
- **Updated:** 14 Sep 2026
- **Also known as:** GHSA-c969-5x3p-vq3v, PYSEC-2026-3532

## What is CVE-2026-57130?

CVE-2026-57130 is a high-severity command injection vulnerability in MervinPraison praisonaiagents, published on 14 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

PraisonAI is a multi-agent teams system. Prior to praisonaiagents 1.6.59, src/praisonai-agents/praisonaiagents/tools/email_tools.py interpolates LLM-controlled from_addr, subject, and query values directly into quoted IMAP SEARCH criteria. Embedded quote, backslash, newline, or null characters can escape the intended criterion and alter IMAP operations when search_emails, reply_email, or archive_email is exposed to an agent with configured email credentials, allowing mailbox data access, modification, deletion, or connection disruption. This issue is fixed in praisonaiagents 1.6.59.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-57130?

3 open source packages ship an affected version, including praisonaiagents.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonaiagents` | PyPI | All versions | 1.6.59 |
| `praisonaiagents` | PyPI | All versions | 1.6.59 |
| `praisonaiagents` | PyPI | All versions | 1.6.59 |

## How do I fix CVE-2026-57130?

Upgrade praisonaiagents to 1.6.59 or later.

## Is CVE-2026-57130 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57130 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57130 and fix it if it is affected.

What it is: CVE-2026-57130 is a high-severity command injection vulnerability in MervinPraison praisonaiagents, published on 14 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57130 exists.

Affected packages and fixed versions:
- praisonaiagents (PyPI): affected all versions; fixed in 1.6.59
- praisonaiagents (PyPI): affected all versions; fixed in 1.6.59
- praisonaiagents (PyPI): affected all versions; fixed in 1.6.59

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57130/ (Markdown: https://insights.sbomify.com/CVE-2026-57130/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57130
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57130
- OSV: https://osv.dev/vulnerability/CVE-2026-57130

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57130/
Summaries are generated and may contain mistakes; the official description above is the record.
