# CVE-2026-57134: PraisonAI MCPSecurity Basic/OAuth authentication policies accept invalid credentials without validation

> Attackers can bypass authentication in PraisonAI MCP security by using Basic or OAuth headers, gaining unauthorized access to protected tools and resources.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 15 Sep 2026
- **Also known as:** GHSA-4qq2-2j2x-x62c

## What is CVE-2026-57134?

CVE-2026-57134 is a high-severity authentication bypass vulnerability in MervinPraison PraisonAI, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PraisonAI is a multi-agent teams system. From 1.5.1 until 1.7.2, MCPSecurity.evaluatePolicy() in src/praisonai-ts/src/mcp/security.ts invokes the configured credential validator only when AuthMethod is api-key or bearer. Basic and OAuth policies accept any non-empty Authorization header without calling auth.validate(), then return an authenticated result, allowing callers with invalid credentials to access MCP tools and resources protected by those policies. This issue is fixed in version 1.7.2.

Weakness: CWE-863 (Incorrect Authorization), CWE-288 (Authentication Bypass Using an Alternate Path or Channel), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-57134?

2 open source packages ship an affected version, including praisonai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai` | npm | From 1.5.1 | 1.7.2 |
| `praisonai` | npm | From 1.5.1 | 1.7.2 |

## How do I fix CVE-2026-57134?

Upgrade praisonai to 1.7.2 or later.

## Is CVE-2026-57134 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57134 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57134 and fix it if it is affected.

What it is: CVE-2026-57134 is a high-severity authentication bypass vulnerability in MervinPraison PraisonAI, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57134 exists.

Affected packages and fixed versions:
- praisonai (npm): affected from 1.5.1; fixed in 1.7.2
- praisonai (npm): affected from 1.5.1; fixed in 1.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57134/ (Markdown: https://insights.sbomify.com/CVE-2026-57134/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57134
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57134
- OSV: https://osv.dev/vulnerability/CVE-2026-57134

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57134/
Summaries are generated and may contain mistakes; the official description above is the record.
