# CVE-2026-57135: PraisonAI SandboxExecutor network-isolated mode does not block non-proxy-aware network clients

> Attackers can bypass network isolation in PraisonAI SandboxExecutor by using clients that ignore proxy settings, accessing internal services or exfiltrating data.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 15 Sep 2026
- **Also known as:** GHSA-gqmf-56h7-rrpf

## What is CVE-2026-57135?

CVE-2026-57135 is a high-severity vulnerability in MervinPraison PraisonAI, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

PraisonAI is a multi-agent teams system. From 1.2.3 until 1.7.2, SandboxExecutor network-isolated mode in src/praisonai-ts/src/cli/features/sandbox-executor.ts uses buildEnv() only to inject invalid http_proxy and https_proxy environment variables and does not establish an operating-system network boundary. Programs that ignore those proxy variables can open sockets directly, allowing supposedly isolated commands to reach localhost, internal services, cloud metadata, or external hosts and potentially exfiltrate data. An initial remediation was released in version 1.7.2.

Weakness: CWE-693 (Protection Mechanism Failure), CWE-653 (Improper Isolation or Compartmentalization)

## Which versions are affected by CVE-2026-57135?

2 open source packages ship an affected version, including praisonai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai` | npm | From 1.2.3 | 1.7.2 |
| `praisonai` | npm | From 1.2.3 | 1.7.2 |

## How do I fix CVE-2026-57135?

Upgrade praisonai to 1.7.2 or later.

## Is CVE-2026-57135 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57135 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57135 and fix it if it is affected.

What it is: CVE-2026-57135 is a high-severity vulnerability in MervinPraison PraisonAI, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57135 exists.

Affected packages and fixed versions:
- praisonai (npm): affected from 1.2.3; fixed in 1.7.2
- praisonai (npm): affected from 1.2.3; fixed in 1.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57135/ (Markdown: https://insights.sbomify.com/CVE-2026-57135/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57135
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57135
- OSV: https://osv.dev/vulnerability/CVE-2026-57135

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57135/
Summaries are generated and may contain mistakes; the official description above is the record.
