# CVE-2026-57136: PraisonAI SandboxExecutor allowedCommands bypass via shell chaining

> Attackers can bypass command validation in PraisonAI to execute arbitrary shell commands via chaining, leading to code execution.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 15 Sep 2026
- **Also known as:** GHSA-vjv9-7m7j-h833

## What is CVE-2026-57136?

CVE-2026-57136 is a high-severity command injection vulnerability in MervinPraison PraisonAI, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

PraisonAI is a multi-agent teams system. From 1.2.3 until 1.7.2, CommandValidator in src/praisonai-ts/src/cli/features/sandbox-executor.ts validates only the first whitespace-delimited executable against allowedCommands, then SandboxExecutor passes the complete command string to sh -c. A command beginning with an allowed executable can append a non-allowlisted command through shell metacharacters, causing arbitrary commands to run with the PraisonAI process privileges. This issue is fixed in version 1.7.2.

Weakness: CWE-863 (Incorrect Authorization), CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-693 (Protection Mechanism Failure)

## Which versions are affected by CVE-2026-57136?

2 open source packages ship an affected version, including praisonai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai` | npm | From 1.2.3 | 1.7.2 |
| `praisonai` | npm | From 1.2.3 | 1.7.2 |

## How do I fix CVE-2026-57136?

Upgrade praisonai to 1.7.2 or later.

## Is CVE-2026-57136 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57136 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57136 and fix it if it is affected.

What it is: CVE-2026-57136 is a high-severity command injection vulnerability in MervinPraison PraisonAI, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57136 exists.

Affected packages and fixed versions:
- praisonai (npm): affected from 1.2.3; fixed in 1.7.2
- praisonai (npm): affected from 1.2.3; fixed in 1.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57136/ (Markdown: https://insights.sbomify.com/CVE-2026-57136/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57136
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57136
- OSV: https://osv.dev/vulnerability/CVE-2026-57136

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57136/
Summaries are generated and may contain mistakes; the official description above is the record.
