# CVE-2026-57138: PraisonAI codeMode sandbox escape via Function constructor

> Attackers can escape the codeMode sandbox in PraisonAI to execute arbitrary code, read secrets, and modify files on the host system.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** GHSA-vmmj-pfw7-fjwp

## What is CVE-2026-57138?

CVE-2026-57138 is a critical code injection vulnerability in MervinPraison PraisonAI, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

PraisonAI is a multi-agent teams system. From 1.4.0 until 1.7.2, codeMode in src/praisonai-ts/src/tools/builtins/code-mode.ts executes untrusted JavaScript with new Function() inside with(sandbox) and relies on a small source-code blocklist plus shadowed process and require properties. Code can use ({}).constructor.constructor to recover the real Function constructor, obtain process and process.mainModule.require, and reach host filesystem and subprocess APIs despite the advertised sandbox. Attackers who control codeMode input can read secrets, modify files, execute commands, or exhaust the host process. This issue is fixed in version 1.7.2.

Weakness: CWE-693 (Protection Mechanism Failure), CWE-184 (Incomplete List of Disallowed Inputs)

## Which versions are affected by CVE-2026-57138?

2 open source packages ship an affected version, including praisonai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai` | npm | From 1.4.0 | 1.7.2 |
| `praisonai` | npm | From 1.4.0 | 1.7.2 |

## How do I fix CVE-2026-57138?

Upgrade praisonai to 1.7.2 or later.

## Is CVE-2026-57138 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57138 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57138 and fix it if it is affected.

What it is: CVE-2026-57138 is a critical code injection vulnerability in MervinPraison PraisonAI, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57138 exists.

Affected packages and fixed versions:
- praisonai (npm): affected from 1.4.0; fixed in 1.7.2
- praisonai (npm): affected from 1.4.0; fixed in 1.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57138/ (Markdown: https://insights.sbomify.com/CVE-2026-57138/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57138
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57138
- OSV: https://osv.dev/vulnerability/CVE-2026-57138

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57138/
Summaries are generated and may contain mistakes; the official description above is the record.
