# CVE-2026-57139: PraisonAI MCPServer exposes unauthenticated HTTP tools/call

> Unauthenticated HTTP access in PraisonAI MCPServer allows attackers to execute tools and read data using server privileges.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** GHSA-j4f3-55x4-r6q2

## What is CVE-2026-57139?

CVE-2026-57139 is a critical missing authorization vulnerability in MervinPraison PraisonAI, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PraisonAI is a multi-agent teams system. From 1.5.0 until 1.7.2, MCPServer.startHttp() in src/praisonai-ts/src/mcp/server.ts binds without a host restriction and forwards every HTTP POST request to handleRequest() without authentication or authorization. Any network client that can reach the port can call tools/list, tools/call, resources/read, or prompts/get, causing registered handlers to run with server-side credentials and process privileges or disclose registered data. An initial remediation was released in version 1.7.2.

Weakness: CWE-862 (Missing Authorization), CWE-306 (Missing Authentication for Critical Functionality), CWE-1188 (Initialization of a Resource with an Insecure Default)

## Which versions are affected by CVE-2026-57139?

2 open source packages ship an affected version, including praisonai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai` | npm | From 1.5.0 | 1.7.2 |
| `praisonai` | npm | From 1.5.0 | 1.7.2 |

## How do I fix CVE-2026-57139?

Upgrade praisonai to 1.7.2 or later.

## Is CVE-2026-57139 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57139 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57139 and fix it if it is affected.

What it is: CVE-2026-57139 is a critical missing authorization vulnerability in MervinPraison PraisonAI, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57139 exists.

Affected packages and fixed versions:
- praisonai (npm): affected from 1.5.0; fixed in 1.7.2
- praisonai (npm): affected from 1.5.0; fixed in 1.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57139/ (Markdown: https://insights.sbomify.com/CVE-2026-57139/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57139
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57139
- OSV: https://osv.dev/vulnerability/CVE-2026-57139

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57139/
Summaries are generated and may contain mistakes; the official description above is the record.
