CVE-2026-57142 PraisonAI recipe workflow policy can be bypassed by declaring and YAML-approving dangerous tools outside TEMPLATE.yaml

High 7.8 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2026-57142?

CVE-2026-57142 is a high-severity vulnerability in MervinPraison PraisonAI, published on 23 Oct 2026.

Official description

PraisonAI is a multi-agent teams system. From version 4.5.87 to before version 4.6.61, PraisonAI recipe execution has a dangerous-tool policy that is supposed to block default-denied tools unless the caller explicitly passes allow_dangerous_tools=True. That policy only checks tools declared in TEMPLATE.yaml requires.tools. For steps-based recipes, the actual execution path loads workflow.yaml with YAMLWorkflowParser. That parser resolves agent-level tools: declarations and preserves top-level approve:. Workflow.start() then installs those YAML-approved tools into the approval context. As a result, an untrusted recipe can omit execute_command from TEMPLATE.yaml requires.tools, declare it in workflow.yaml agents.*.tools, and add top-level approve: [execute_command]. The caller did not set allow_dangerous_tools=True, but the recipe policy allows the recipe and the workflow approval path self-approves the critical shell tool. This issue has been patched in version 4.6.61.

Weakness: CWE-94, CWE-863, CWE-78

Which versions are affected by CVE-2026-57142?

3 open source packages ship an affected version, including praisonai.

PackageAffectedFixed in
praisonai PyPIFrom 4.5.874.6.61
praisonai PyPIFrom 4.5.874.6.61
praisonai PyPIFrom 4.5.874.6.61

How do I fix CVE-2026-57142?

Upgrade praisonai to 4.6.61 or later.

Is CVE-2026-57142 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57142 exists.

Sources

Also known as GHSA-7qw2-w5rc-37x2, PYSEC-2026-3505.

Is CVE-2026-57142 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free