# CVE-2026-57142: PraisonAI recipe workflow policy can be bypassed by declaring and YAML-approving dangerous tools outside TEMPLATE.yaml


- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 23 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-7qw2-w5rc-37x2, PYSEC-2026-3505

## What is CVE-2026-57142?

CVE-2026-57142 is a high-severity vulnerability in MervinPraison PraisonAI, published on 23 Oct 2026. 

### Official description

PraisonAI is a multi-agent teams system. From version 4.5.87 to before version 4.6.61, PraisonAI recipe execution has a dangerous-tool policy that is supposed to block default-denied tools unless the caller explicitly passes allow_dangerous_tools=True. That policy only checks tools declared in TEMPLATE.yaml requires.tools. For steps-based recipes, the actual execution path loads workflow.yaml with YAMLWorkflowParser. That parser resolves agent-level tools: declarations and preserves top-level approve:. Workflow.start() then installs those YAML-approved tools into the approval context. As a result, an untrusted recipe can omit execute_command from TEMPLATE.yaml requires.tools, declare it in workflow.yaml agents.*.tools, and add top-level approve: [execute_command]. The caller did not set allow_dangerous_tools=True, but the recipe policy allows the recipe and the workflow approval path self-approves the critical shell tool. This issue has been patched in version 4.6.61.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-863 (Incorrect Authorization), CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-57142?

3 open source packages ship an affected version, including praisonai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai` | PyPI | From 4.5.87 | 4.6.61 |
| `praisonai` | PyPI | From 4.5.87 | 4.6.61 |
| `praisonai` | PyPI | From 4.5.87 | 4.6.61 |

## How do I fix CVE-2026-57142?

Upgrade praisonai to 4.6.61 or later.

## Is CVE-2026-57142 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57142 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57142 and fix it if it is affected.

What it is: CVE-2026-57142 is a high-severity vulnerability in MervinPraison PraisonAI, published on 23 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57142 exists.

Affected packages and fixed versions:
- praisonai (PyPI): affected from 4.5.87; fixed in 4.6.61
- praisonai (PyPI): affected from 4.5.87; fixed in 4.6.61
- praisonai (PyPI): affected from 4.5.87; fixed in 4.6.61

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57142/ (Markdown: https://insights.sbomify.com/CVE-2026-57142/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57142
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57142
- OSV: https://osv.dev/vulnerability/CVE-2026-57142

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57142/
Summaries are generated and may contain mistakes; the official description above is the record.
