# CVE-2026-57146: PraisonAI A2U incomplete authentication fix leaves current serve command unauthenticated by default


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 23 Oct 2026
- **Updated:** 23 Oct 2026
- **Also known as:** GHSA-jxcw-qp4h-6jfq, PYSEC-2026-3515

## What is CVE-2026-57146?

CVE-2026-57146 is a high-severity vulnerability in MervinPraison PraisonAI, published on 23 Oct 2026. 

### Official description

PraisonAI is a multi-agent teams system. From version 4.5.115 to before version 4.6.61, the published A2U advisory GHSA-f292-66h9-fpmf says unauthenticated A2U event streaming was fixed in praisonai 4.5.115. Current head still exposes the same A2U subscription and event routes without authentication when the operator starts the documented CLI entrypoint. The current CLI wrapper does not expose --api-key, does not install the common API-key middleware, and does not generate a token for A2U. It calls create_a2u_routes(app) directly. That helper only enforces auth if A2U_AUTH_TOKEN is already present; if the variable is missing, _authenticate_request() returns None and treats auth as disabled. This issue has been patched in version 4.6.61.

Weakness: CWE-306 (Missing Authentication for Critical Functionality), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-57146?

3 open source packages ship an affected version, including praisonai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai` | PyPI | From 4.5.115 | 4.6.61 |
| `praisonai` | PyPI | From 4.5.115 | 4.6.61 |
| `praisonai` | PyPI | From 4.5.115 | 4.6.61 |

## How do I fix CVE-2026-57146?

Upgrade praisonai to 4.6.61 or later.

## Is CVE-2026-57146 being exploited?

There is no known exploitation of CVE-2026-57146 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57146 and fix it if it is affected.

What it is: CVE-2026-57146 is a high-severity vulnerability in MervinPraison PraisonAI, published on 23 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-57146 in the wild and no public exploit code.

Affected packages and fixed versions:
- praisonai (PyPI): affected from 4.5.115; fixed in 4.6.61
- praisonai (PyPI): affected from 4.5.115; fixed in 4.6.61
- praisonai (PyPI): affected from 4.5.115; fixed in 4.6.61

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57146/ (Markdown: https://insights.sbomify.com/CVE-2026-57146/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57146
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57146
- OSV: https://osv.dev/vulnerability/CVE-2026-57146

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57146/
Summaries are generated and may contain mistakes; the official description above is the record.
