# CVE-2026-57147: praisonai-platform: default JWT signing secret 'dev-secret-change-me' enables token forgery

> Attackers can forge JWT tokens using a hardcoded default secret to impersonate users and access protected API routes in PraisonAI.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** GHSA-cwj8-7gp2-ggcw, PYSEC-2026-3524

## What is CVE-2026-57147?

CVE-2026-57147 is a critical vulnerability in MervinPraison PraisonAI, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PraisonAI is a multi-agent teams system. Prior to 0.1.6, praisonai_platform/services/auth_service.py assigns the public dev-secret-change-me value to JWT_SECRET when PLATFORM_JWT_SECRET is unset, and its production guard does not run when PLATFORM_ENV is also unset because that setting defaults to dev. A remote unauthenticated attacker can mint an HS256 token with an arbitrary sub and email, and the platform's AuthService._verify_token() and get_current_user dependency accept the forged identity for protected API routes. This vulnerability is fixed in praisonai-platform 0.1.6.

Weakness: CWE-798 (Use of Hard-coded Credentials), CWE-1188 (Initialization of a Resource with an Insecure Default)

## Which versions are affected by CVE-2026-57147?

3 open source packages ship an affected version, including praisonai-platform.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai-platform` | PyPI | All versions | 0.1.6 |
| `praisonai-platform` | PyPI | All versions | 0.1.6 |
| `praisonai-platform` | PyPI | All versions | 0.1.6 |

## How do I fix CVE-2026-57147?

Upgrade praisonai-platform to 0.1.6 or later.

## Is CVE-2026-57147 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57147 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57147 and fix it if it is affected.

What it is: CVE-2026-57147 is a critical vulnerability in MervinPraison PraisonAI, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57147 exists.

Affected packages and fixed versions:
- praisonai-platform (PyPI): affected all versions; fixed in 0.1.6
- praisonai-platform (PyPI): affected all versions; fixed in 0.1.6
- praisonai-platform (PyPI): affected all versions; fixed in 0.1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57147/ (Markdown: https://insights.sbomify.com/CVE-2026-57147/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57147
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57147
- OSV: https://osv.dev/vulnerability/CVE-2026-57147

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57147/
Summaries are generated and may contain mistakes; the official description above is the record.
