# CVE-2026-57149: plone.app.portlets Vulnerable to Remote Code Execution via TALES Injection

> Authenticated users can execute arbitrary code via TALES injection in Classic portlets, leading to server-side privilege escalation.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Sep 2026
- **Updated:** 22 Sep 2026
- **Also known as:** GHSA-rr49-f9g6-c9r5, PYSEC-2026-4138

## What is CVE-2026-57149?

CVE-2026-57149 is a critical code injection vulnerability in plone.app.portlets, published on 22 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

plone.app.portlets.portlets provides a Plone-specific user interface for plone.portlets, as well as a standard set of portlets that ship with Plone. Starting in version 5.0.0 and prior to versions 5.0.8, 6.0.4, and 7.0.2, the Classic portlet (plone.app.portlets.portlets.classic) used its user-supplied template/macro fields to build a TALES path expression that was then evaluated by the TAL path() helper. Because the value was interpreted as a full TALES expression, a user able to add or edit a Classic portlet could supply a crafted value that escapes simple path traversal and is evaluated as arbitrary code. This is exploitable by any authenticated user who can configure a Classic portlet - which, with the default role map, includes regular users on their personal dashboard. The result is code execution in the context of the Plone process, i.e. a privilege escalation across the trust boundary between an authenticated web user and the server-side process. The problem has been patched in `plone.app.portlets` 5.0.8, 6.0.4, and 7.0.2. Some workarounds are available.  Restrict who can manage portlets: remove the `plone.app.portlets.ManageOwnPortlets` permission from untrusted roles, and limit Manage portlets to trusted administrators (usually this is already restricted to the Manager and Site Administrator roles).  Where the Classic portlet is not needed, unregister it so it cannot be added. This would need to be done by editing a `portlets.xml` in your own code. One may also effectively disable showing the classic portlet by customising its template. In the Zope Management Interface go to the `portal_view_customizations` tool, locate the `classic.pt` template and click it. Click the Customize button.  Remove all text and replace it with `<div>The classic portlet was disabled.</div>`. (This is not a recommended way of customizing a template, but in this case it is quite effective.)

Weakness: CWE-95 (Improper Neutralization of Directives in Dynamically Evaluated Code)

## Which versions are affected by CVE-2026-57149?

7 open source packages ship an affected version, including plone.app.portlets and plone-app-portlets.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `plone.app.portlets` | PyPI | From 5.0.0 | 5.0.8 |
| `plone.app.portlets` | PyPI | From 6.0.0 | 6.0.4 |
| `plone.app.portlets` | PyPI | From 7.0.0 | 7.0.2 |
| `plone-app-portlets` | PyPI | From 5.0.0 | 5.0.8, 6.0.4, 7.0.2, 5.0.8 |
| `plone-app-portlets` | PyPI | From 5.0.0 | 5.0.8 |
| `plone-app-portlets` | PyPI | From 6.0.0 | 6.0.4 |
| `plone-app-portlets` | PyPI | From 7.0.0 | 7.0.2 |

## How do I fix CVE-2026-57149?

Upgrade plone.app.portlets to a fixed version for your release line: 5.0.8, 6.0.4 or 7.0.2.

## Is CVE-2026-57149 being exploited?

There is no known exploitation of CVE-2026-57149 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57149 and fix it if it is affected.

What it is: CVE-2026-57149 is a critical code injection vulnerability in plone.app.portlets, published on 22 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-57149 in the wild and no public exploit code.

Affected packages and fixed versions:
- plone.app.portlets (PyPI): affected from 5.0.0; fixed in 5.0.8
- plone.app.portlets (PyPI): affected from 6.0.0; fixed in 6.0.4
- plone.app.portlets (PyPI): affected from 7.0.0; fixed in 7.0.2
- plone-app-portlets (PyPI): affected from 5.0.0; fixed in 5.0.8, 6.0.4, 7.0.2, 5.0.8
- plone-app-portlets (PyPI): affected from 5.0.0; fixed in 5.0.8
- plone-app-portlets (PyPI): affected from 6.0.0; fixed in 6.0.4
- plone-app-portlets (PyPI): affected from 7.0.0; fixed in 7.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57149/ (Markdown: https://insights.sbomify.com/CVE-2026-57149/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57149
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57149
- OSV: https://osv.dev/vulnerability/CVE-2026-57149

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57149/
Summaries are generated and may contain mistakes; the official description above is the record.
