# CVE-2026-57155: OPNsense: Root RCE via Arbitrary File Write in GeoIP Alias Importer

> A user with Firewall Alias Edit privilege can exploit path traversal in GeoIP import to write files as root, leading to remote code execution and full system compromise.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 Oct 2026
- **Updated:** 15 Oct 2026
- **Also known as:** GHSA-wjqq-rfmm-v5h3

## What is CVE-2026-57155?

CVE-2026-57155 is a critical path traversal vulnerability in opnsense core, published on 15 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OPNsense is a FreeBSD based firewall and routing platform. Prior to version 26.1.11, the Firewall Alias GeoIP importer's process_zip() and process_gzip() paths in src/opnsense/scripts/filter/lib/alias/geoip.py use an unvalidated CSV country_code value to construct output filenames below /usr/local/share/GeoIP/alias. A user with Firewall Alias Edit privilege can configure an attacker-controlled GeoIP source URL and supply an archive whose country code traverses into another existing directory, causing attacker-controlled content to be written as root with an -IPv4 or -IPv6 suffix. A crafted newsyslog fragment and oversized log file can use the default hourly root cron job to execute commands as root, resulting in complete firewall compromise. This issue is fixed in version 26.1.11.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-73 (External Control of File Name or Path), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-57155?


## How do I fix CVE-2026-57155?

No fix has been published for CVE-2026-57155 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-57155 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57155 exists.

Public exploit code:

- OPNsense Root RCE (CVE-2026-57155) (github_poc): https://github.com/babyshen/CVE-2026-57155

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57155 and fix it if it is affected.

What it is: CVE-2026-57155 is a critical path traversal vulnerability in opnsense core, published on 15 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57155 exists.

Affected product: opnsense core. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57155/ (Markdown: https://insights.sbomify.com/CVE-2026-57155/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57155
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57155
- OSV: https://osv.dev/vulnerability/CVE-2026-57155

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57155/
Summaries are generated and may contain mistakes; the official description above is the record.
