CVE-2026-57171 Trestle is vulnerable to arbitrary file write via path traversal in author generate commands (Incomplete fix of CVE-2026-46345)
Attackers can write arbitrary files or delete directories via path traversal in Trestle generate commands, potentially leading to code execution in CI pipelines.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-57171?
CVE-2026-57171 is a high-severity path traversal vulnerability in oscal-compass compliance-trestle, published on 25 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Compliance-trestle (Trestle) is a Python SDK and command-line tool for managing OSCAL compliance documents. In versions before 3.12.4 and versions 4.0.0 through 4.0.3, the catalog-generate, profile-generate, and ssp-generate author commands write generated Markdown to an attacker-influenced output path without path-traversal validation, allowing arbitrary file write outside the Trestle workspace. These commands join the user-supplied output argument onto the Trestle root and write to the result, but guard it only with an is_directory_name_allowed() task-name-collision check rather than the PathSecurityValidator.validate_local_path() guard used by the jinja command, so an absolute path or one containing traversal sequences escapes the workspace and writes files under an attacker-chosen location as the invoking process owner. The security boundary is crossed when a trusted CI job, shared service, or wrapper derives the output argument from repository-controlled, tenant-controlled, or otherwise untrusted data while expecting output to stay inside the workspace. When --force-overwrite is used, the selected output directory is first recursively deleted, extending the primitive to destruction of an attacker-chosen directory tree and enabling indirect code execution by overwriting files a pipeline later runs. This issue is fixed in versions 3.12.4 and 4.1.0.
Weakness: CWE-22
Which versions are affected by CVE-2026-57171?
5 open source packages ship an affected version, including compliance-trestle.
| Package | Affected | Fixed in |
|---|---|---|
compliance-trestle PyPI | All versions | 3.12.4, 4.1.0 |
compliance-trestle PyPI | All versions | 3.12.4 |
compliance-trestle PyPI | All versions | 3.12.4 |
compliance-trestle PyPI | From 4.0.0 | 4.1.0 |
compliance-trestle PyPI | From 4.0.0 | 4.1.0 |
How do I fix CVE-2026-57171?
Upgrade compliance-trestle to a fixed version for your release line: 3.12.4 or 4.1.0.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2026-57171 being exploited?
There is no known exploitation of CVE-2026-57171 in the wild and no public exploit code.
Sources
Also known as GHSA-r4vp-3vw6-r2x5, PYSEC-2026-4030.