# CVE-2026-57173: vLLM: Unauthenticated audio decompression-bomb DoS in /v1/chat/completions

> Unauthenticated attackers can crash vLLM workers by sending small compressed audio inputs that cause excessive memory allocation.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Sep 2026
- **Updated:** 18 Sep 2026
- **Also known as:** GHSA-hcwq-8wjf-3gcr, MINI-2mgx-c97m-5vw2, MINI-8w89-pg8g-gxhp, MINI-h739-jxf4-8r39, PYSEC-2026-4179

## What is CVE-2026-57173?

CVE-2026-57173 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 16 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

vLLM is an inference and serving engine for large language models. Prior to 0.24.0, the input_audio handling path for /v1/chat/completions calls AudioMediaIO.load_bytes or AudioMediaIO.load_file without passing VLLM_MAX_AUDIO_DECODE_DURATION_S to the shared audio decoder. An unauthenticated client can therefore submit a small compressed audio input that expands into a very large float32 PCM allocation, bypassing the duration guard already used by /v1/audio/transcriptions and causing an out-of-memory worker crash. Inline data URLs reach this path without being bounded by VLLM_AUDIO_FETCH_TIMEOUT. The issue affects deployments serving an audio-capable model, and authentication changes only the deployment-specific reachability. This issue is fixed in version 0.24.0.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-57173?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | All versions | 0.24.0 |
| `vllm` | PyPI | All versions | 0.24.0 |
| `vllm` | PyPI | All versions | 0.24.0 |

Products: Vllm Vllm.

## How do I fix CVE-2026-57173?

Upgrade vllm to 0.24.0 or later.

## Is CVE-2026-57173 being exploited?

There is no known exploitation of CVE-2026-57173 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57173 and fix it if it is affected.

What it is: CVE-2026-57173 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 16 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-57173 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected all versions; fixed in 0.24.0
- vllm (PyPI): affected all versions; fixed in 0.24.0
- vllm (PyPI): affected all versions; fixed in 0.24.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57173/ (Markdown: https://insights.sbomify.com/CVE-2026-57173/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57173
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57173
- OSV: https://osv.dev/vulnerability/CVE-2026-57173

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57173/
Summaries are generated and may contain mistakes; the official description above is the record.
