# CVE-2026-57176: social-auth-core Vulnerable to Account Takeover via Identity Binding Flaw in Vend Backend

> Attackers can hijack accounts by exploiting user ID collisions across multiple Vend shops in the social-auth-core library.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** DEBIAN-CVE-2026-57176, GHSA-fp7w-m676-w7gc, PYSEC-2026-4166, UBUNTU-CVE-2026-57176

## What is CVE-2026-57176?

CVE-2026-57176 is a medium-severity authentication bypass vulnerability in python-social-auth social-core, published on 24 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Python Social Auth is a social authentication/registration mechanism. Prior to version 5.0.0, the Vend OAuth2 backend used only the numeric Vend user_id as the social-auth UID. When multiple Vend shops authenticate through the same application, users from different shops with the same internal Vend user ID could collide in the social-auth association table. A user from one shop could then be authenticated as the local account previously associated with the same numeric user ID from another shop. The issue affects applications using the Vend OAuth2 backend with more than one Vend shop. Version 5.0.0 patches the issue.

Weakness: CWE-289 (Authentication Bypass by Alternate Name)

## Which versions are affected by CVE-2026-57176?

3 open source packages ship an affected version, including social-auth-core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `social-auth-core` | PyPI | All versions | 5.0.0 |
| `social-auth-core` | PyPI | All versions | 5.0.0 |
| `social-auth-core` | PyPI | All versions | 5.0.0 |

## How do I fix CVE-2026-57176?

Upgrade social-auth-core to 5.0.0 or later.

## Is CVE-2026-57176 being exploited?

There is no known exploitation of CVE-2026-57176 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57176 and fix it if it is affected.

What it is: CVE-2026-57176 is a medium-severity authentication bypass vulnerability in python-social-auth social-core, published on 24 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-57176 in the wild and no public exploit code.

Affected packages and fixed versions:
- social-auth-core (PyPI): affected all versions; fixed in 5.0.0
- social-auth-core (PyPI): affected all versions; fixed in 5.0.0
- social-auth-core (PyPI): affected all versions; fixed in 5.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57176/ (Markdown: https://insights.sbomify.com/CVE-2026-57176/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57176
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57176
- OSV: https://osv.dev/vulnerability/CVE-2026-57176

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57176/
Summaries are generated and may contain mistakes; the official description above is the record.
