{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-57185 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-57185 is a medium-severity vulnerability in asterisk, published on 27 Oct 2026."},"fix_prompt":"Check this codebase for CVE-2026-57185 and fix it if it is affected.\n\nWhat it is: CVE-2026-57185 is a medium-severity vulnerability in asterisk, published on 27 Oct 2026. \nExploitation: There is no known exploitation of CVE-2026-57185 in the wild and no public exploit code.\n\nAffected product: asterisk. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-57185/ (Markdown: https://insights.sbomify.com/CVE-2026-57185/index.md)","id":"CVE-2026-57185","markdown":"https://insights.sbomify.com/CVE-2026-57185/index.md","name":"CVE-2026-57185","record":{"aliases":["DEBIAN-CVE-2026-57185","GHSA-8jw3-ccr9-xrmf","UBUNTU-CVE-2026-57185"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-170","name":"Improper Null Termination"},{"id":"CWE-126","name":"Buffer Over-read"}],"description":"Asterisk is an open source private branch exchange and telephony toolkit. Prior to Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3, an authenticated attacker may crash Asterisk through a buffer over-read in the `PJSIP MWI body parser` by sending a carefully crafted `SIP NOTIFY` request. The attacker must pass SIP authentication using either a username/password or `source IP address matching`. This issue is fixed in Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Asterisk: Buffer over-read in Asterisk PJSIP MWI body parser","id":"CVE-2026-57185","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":null,"year":"2026"},"n_packages":0,"n_references":15,"next":{"headline":"Asterisk: CVE-2022-37325 fix is absent from current chan_ooh323 Q.931 party-number parser","id":"CVE-2026-57186"},"packages":[],"prev":{"headline":"Asterisk: Out-of-Bounds Read in Q.931 Information Element Parser (H.323 Addon)","id":"CVE-2026-57184"},"products":["asterisk","certified-asterisk"],"published":"2026-10-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2026-10-27","vendors":["asterisk"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2026-57185/"}