# CVE-2026-57185: Asterisk: Buffer over-read in Asterisk PJSIP MWI body parser


- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 27 Oct 2026
- **Updated:** 27 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-57185, GHSA-8jw3-ccr9-xrmf, UBUNTU-CVE-2026-57185

## What is CVE-2026-57185?

CVE-2026-57185 is a medium-severity vulnerability in asterisk, published on 27 Oct 2026. 

### Official description

Asterisk is an open source private branch exchange and telephony toolkit. Prior to Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3, an authenticated attacker may crash Asterisk through a buffer over-read in the `PJSIP MWI body parser` by sending a carefully crafted `SIP NOTIFY` request. The attacker must pass SIP authentication using either a username/password or `source IP address matching`. This issue is fixed in Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3.

Weakness: CWE-170 (Improper Null Termination), CWE-126 (Buffer Over-read)

## Which versions are affected by CVE-2026-57185?


## How do I fix CVE-2026-57185?

Upgrade to a fixed version.

## Is CVE-2026-57185 being exploited?

There is no known exploitation of CVE-2026-57185 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57185 and fix it if it is affected.

What it is: CVE-2026-57185 is a medium-severity vulnerability in asterisk, published on 27 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-57185 in the wild and no public exploit code.

Affected product: asterisk. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57185/ (Markdown: https://insights.sbomify.com/CVE-2026-57185/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57185
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57185
- OSV: https://osv.dev/vulnerability/CVE-2026-57185

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57185/
Summaries are generated and may contain mistakes; the official description above is the record.
