# CVE-2026-57194: Asterisk: chan_unistim DIALPAGE digit handling can overflow phone_number and crash Asterisk


- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 27 Oct 2026
- **Updated:** 27 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-57194, GHSA-3g56-cgrh-95p5, UBUNTU-CVE-2026-57194

## What is CVE-2026-57194?

CVE-2026-57194 is a medium-severity vulnerability in asterisk, published on 27 Oct 2026. 

### Official description

Asterisk is an open source private branch exchange and telephony toolkit. Prior to Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3, an out-of-bounds write in `chan_unistim` `DIALPAGE` digit handling can overflow the `phone_number` field and crash Asterisk when an attacker sends a carefully crafted incoming request packet. The `chan_unistim` module must be loaded and configured with a valid `UNISTIM UDP port` that the attacker can reach. The attacker must register as a configured `phone MAC`, or the deployment must have an equivalent `production/autoprovisioning` path that allows the client to reach the main page. This issue is fixed in Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2026-57194?


## How do I fix CVE-2026-57194?

Upgrade to a fixed version.

## Is CVE-2026-57194 being exploited?

There is no known exploitation of CVE-2026-57194 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57194 and fix it if it is affected.

What it is: CVE-2026-57194 is a medium-severity vulnerability in asterisk, published on 27 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-57194 in the wild and no public exploit code.

Affected product: asterisk. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57194/ (Markdown: https://insights.sbomify.com/CVE-2026-57194/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57194
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57194
- OSV: https://osv.dev/vulnerability/CVE-2026-57194

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57194/
Summaries are generated and may contain mistakes; the official description above is the record.
