# CVE-2026-57196: Asterisk: Reflected XSS in Phone Provisioning HTTP Error Pages


- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 26 Oct 2026
- **Updated:** 26 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-57196, GHSA-4pgv-j3mr-3rcp, UBUNTU-CVE-2026-57196

## What is CVE-2026-57196?

CVE-2026-57196 is a low-severity vulnerability in asterisk, published on 26 Oct 2026. 

### Official description

Asterisk is an open source private branch exchange and telephony toolkit. Prior to Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3, an unauthenticated attacker may use reflected cross-site scripting in `phone provisioning HTTP error pages` to retrieve an authorized user's `AMI session cookie` and impersonate that user when `res_phoneprov` is enabled. The Asterisk HTTP web server, Asterisk Manager Interface (AMI), and AMI access via HTTP must all be enabled; each is disabled by default. The attacker must be able to connect to the HTTP server, which binds only to `127.0.0.1` by default even when enabled, and must convince the authorized user to click a malicious link. This issue is fixed in Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-57196?


## How do I fix CVE-2026-57196?

Upgrade to a fixed version.

## Is CVE-2026-57196 being exploited?

There is no known exploitation of CVE-2026-57196 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57196 and fix it if it is affected.

What it is: CVE-2026-57196 is a low-severity vulnerability in asterisk, published on 26 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-57196 in the wild and no public exploit code.

Affected product: asterisk. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57196/ (Markdown: https://insights.sbomify.com/CVE-2026-57196/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57196
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57196
- OSV: https://osv.dev/vulnerability/CVE-2026-57196

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57196/
Summaries are generated and may contain mistakes; the official description above is the record.
