# CVE-2026-57197: Asterisk: Heap Buffer Overflow in OGG/Speex File Playback (format_ogg_speex)


- **Severity:** High 7.7 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 27 Oct 2026
- **Updated:** 27 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-57197, GHSA-8jhw-m2hg-vp3h, UBUNTU-CVE-2026-57197

## What is CVE-2026-57197?

CVE-2026-57197 is a high-severity vulnerability in asterisk, published on 27 Oct 2026. 

### Official description

Asterisk is an open source private branch exchange and telephony toolkit. Prior to Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3, an unbounded `memcpy` of `OGG/Speex` packet data in `format_ogg_speex` can cause a heap buffer overflow and crash Asterisk when reading a file containing corrupted Speex audio. The attacker must create the file and make it available to Asterisk either through sufficiently elevated privileges or by convincing an Asterisk administrator to make it available. Asterisk must also be configured to play that file. This issue is fixed in Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3.

Weakness: CWE-787 (Out-of-bounds Write), CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2026-57197?


## How do I fix CVE-2026-57197?

Upgrade to a fixed version.

## Is CVE-2026-57197 being exploited?

There is no known exploitation of CVE-2026-57197 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57197 and fix it if it is affected.

What it is: CVE-2026-57197 is a high-severity vulnerability in asterisk, published on 27 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-57197 in the wild and no public exploit code.

Affected product: asterisk. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57197/ (Markdown: https://insights.sbomify.com/CVE-2026-57197/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57197
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57197
- OSV: https://osv.dev/vulnerability/CVE-2026-57197

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57197/
Summaries are generated and may contain mistakes; the official description above is the record.
