# CVE-2026-57200: Asterisk: ARI REST-over-WebSocket read-only bypass allows arbitrary module path load and conditional RCE


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 27 Oct 2026
- **Updated:** 27 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-57200, GHSA-wcvv-g26m-wx5c, UBUNTU-CVE-2026-57200

## What is CVE-2026-57200?

CVE-2026-57200 is a high-severity vulnerability in asterisk, published on 27 Oct 2026. 

### Official description

Asterisk is an open source private branch exchange and telephony toolkit. Prior to Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 22.8-cert3, an authenticated attacker with read-only permissions for the `Asterisk REST Interface (ARI)` may, under certain conditions, execute write operations through `REST-over-WebSocket`. The authorization bypass permits `arbitrary module path` loading and conditional remote code execution. The Asterisk HTTP web server must be enabled and reachable, and the attacker must already have valid `read-only ARI credentials`. HTTP is disabled by default and binds only to 127.0.0.1 by default even when enabled. This issue is fixed in Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 22.8-cert3.

Weakness: CWE-863 (Incorrect Authorization), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-57200?


## How do I fix CVE-2026-57200?

Upgrade to a fixed version.

## Is CVE-2026-57200 being exploited?

There is no known exploitation of CVE-2026-57200 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57200 and fix it if it is affected.

What it is: CVE-2026-57200 is a high-severity vulnerability in asterisk, published on 27 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-57200 in the wild and no public exploit code.

Affected product: asterisk. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57200/ (Markdown: https://insights.sbomify.com/CVE-2026-57200/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57200
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57200
- OSV: https://osv.dev/vulnerability/CVE-2026-57200

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57200/
Summaries are generated and may contain mistakes; the official description above is the record.
