# CVE-2026-57202: Asterisk: ARI setChannelVar bypasses live_dangerously and permits FILE() writes


- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 27 Oct 2026
- **Updated:** 28 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-57202, GHSA-vrfp-mg3q-3959, UBUNTU-CVE-2026-57202

## What is CVE-2026-57202?

CVE-2026-57202 is a high-severity vulnerability in asterisk, published on 27 Oct 2026. 

### Official description

Asterisk is an open source private branch exchange and telephony toolkit. Prior to Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3, an authenticated Asterisk REST Interface (ARI) attacker with read-only privileges may use `setChannelVar` to execute write dialplan functions, including `FILE()` writes, even when `live_dangerously` in `asterisk.conf` is set to no. The Asterisk HTTP web server must be enabled and reachable, and the attacker must already have valid `read-only ARI credentials`. HTTP is disabled by default and binds only to 127.0.0.1 by default even when enabled. This issue is fixed in Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3.

Weakness: CWE-267 (Privilege Defined With Unsafe Actions), CWE-1220 (Insufficient Granularity of Access Control)

## Which versions are affected by CVE-2026-57202?


## How do I fix CVE-2026-57202?

Upgrade to a fixed version.

## Is CVE-2026-57202 being exploited?

There is no known exploitation of CVE-2026-57202 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57202 and fix it if it is affected.

What it is: CVE-2026-57202 is a high-severity vulnerability in asterisk, published on 27 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-57202 in the wild and no public exploit code.

Affected product: asterisk. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57202/ (Markdown: https://insights.sbomify.com/CVE-2026-57202/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57202
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57202
- OSV: https://osv.dev/vulnerability/CVE-2026-57202

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57202/
Summaries are generated and may contain mistakes; the official description above is the record.
