# CVE-2026-57208: Entire CLI: Path traversal in checkpoint session metadata allows arbitrary file write during resume/rewind


- **Severity:** Medium 6.2 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:N/VI:L/VA:N/SC:N/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 23 Oct 2026
- **Updated:** 23 Oct 2026
- **Also known as:** GHSA-2h46-9x5w-4wf7, GO-2026-5063

## What is CVE-2026-57208?

CVE-2026-57208 is a medium-severity vulnerability in entireio cli, published on 23 Oct 2026. 

### Official description

Entire CLI hooks into Git workflows to capture AI agent sessions. Prior to version 0.7.7, a path traversal vulnerability in Entire CLI allows an attacker with push access to the checkpoints repository to craft malicious checkpoint metadata that causes entire session resume or entire checkpoint rewind to write attacker-controlled transcript data outside of the expected session directory. The issue occurs because checkpoint metadata is fetched from the remote entire/checkpoints/v1 branch and the SessionID field was used to construct filesystem paths without validation in the restore path. A malicious SessionID containing absolute paths or path traversal sequences could cause arbitrary files on the victim’s machine to be overwritten. This issue has been patched in version 0.7.7.

Weakness: CWE-73 (External Control of File Name or Path), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-57208?

3 open source packages ship an affected version, including github.com/entireio/cli.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/entireio/cli` | Go | All versions | 0.7.7 |
| `github.com/entireio/cli` | Go | All versions | 0.7.7 |
| `github.com/entireio/cli` | Go | All versions | 0.7.7 |

## How do I fix CVE-2026-57208?

Upgrade github.com/entireio/cli to 0.7.7 or later.

## Is CVE-2026-57208 being exploited?

There is no known exploitation of CVE-2026-57208 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57208 and fix it if it is affected.

What it is: CVE-2026-57208 is a medium-severity vulnerability in entireio cli, published on 23 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-57208 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/entireio/cli (Go): affected all versions; fixed in 0.7.7
- github.com/entireio/cli (Go): affected all versions; fixed in 0.7.7
- github.com/entireio/cli (Go): affected all versions; fixed in 0.7.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57208/ (Markdown: https://insights.sbomify.com/CVE-2026-57208/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57208
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57208
- OSV: https://osv.dev/vulnerability/CVE-2026-57208

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57208/
Summaries are generated and may contain mistakes; the official description above is the record.
