# CVE-2026-57209: Heimdall: Forwarded Header Injection via Unsanitized Host Header in Proxy Mode


- **Severity:** High 7.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 23 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-4jgr-pg2m-m988, GO-2026-5125

## What is CVE-2026-57209?

CVE-2026-57209 is a high-severity vulnerability in dadrus heimdall, published on 23 Oct 2026. 

### Official description

Heimdall is a cloud native Identity Aware Proxy and Access Control Decision service. Prior to version 0.17.17, when Heimdall operates in proxy mode, it constructs the Forwarded HTTP header after executing the matched rule pipeline by inserting the incoming request's Host header value directly into the header string without sanitizing commas or semicolons. This allows an attacker to inject additional parameters into the Forwarded header, potentially spoofing IP addresses for upstream services. This issue has been patched in version 0.17.17.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-57209?

3 open source packages ship an affected version, including github.com/dadrus/heimdall.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/dadrus/heimdall` | Go | All versions | 0.17.17 |
| `github.com/dadrus/heimdall` | Go | All versions | 0.17.17 |
| `github.com/dadrus/heimdall` | Go | All versions | 0.17.17 |

## How do I fix CVE-2026-57209?

Upgrade github.com/dadrus/heimdall to 0.17.17 or later.

## Is CVE-2026-57209 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57209 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57209 and fix it if it is affected.

What it is: CVE-2026-57209 is a high-severity vulnerability in dadrus heimdall, published on 23 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57209 exists.

Affected packages and fixed versions:
- github.com/dadrus/heimdall (Go): affected all versions; fixed in 0.17.17
- github.com/dadrus/heimdall (Go): affected all versions; fixed in 0.17.17
- github.com/dadrus/heimdall (Go): affected all versions; fixed in 0.17.17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57209/ (Markdown: https://insights.sbomify.com/CVE-2026-57209/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57209
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57209
- OSV: https://osv.dev/vulnerability/CVE-2026-57209

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57209/
Summaries are generated and may contain mistakes; the official description above is the record.
