CVE-2026-57211 RabbitMQ: UNC SSRF affecting the management UI on Windows

Medium 6.5 Published Updated

An attacker can trigger Server-Side Request Forgery in RabbitMQ's management UI on Windows to access attacker-controlled UNC paths, requiring multiple management plugins.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-57211?

CVE-2026-57211 is a medium-severity server-side request forgery vulnerability in Broadcom Rabbitmq Server, published on 10 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

RabbitMQ is a messaging and streaming broker. Prior to 4.1.11 and 4.2.6 on Windows, the RabbitMQ management plugin static file handler rabbit_mgmt_wm_static can pass URL-encoded backslashes to erl_prim_loader:read_file_info before path validation when multiple management extension plugins are enabled, causing outbound DNS and SMB requests to attacker-controlled UNC paths. This issue is fixed in versions 4.1.11 and 4.2.6.

Weakness: CWE-918, CWE-36

Which versions are affected by CVE-2026-57211?

It affects 1 product.

Products include Broadcom Rabbitmq Server.

How do I fix CVE-2026-57211?

Upgrade to a fixed version.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2026-57211 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57211 exists.

All Broadcom Rabbitmq Server vulnerabilities

Sources

Also known as AZL-92361, GHSA-7v84-m3g5-vxq6, UBUNTU-CVE-2026-57211.

Is CVE-2026-57211 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free