# CVE-2026-57211: RabbitMQ: UNC SSRF affecting the management UI on Windows

> An attacker can trigger Server-Side Request Forgery in RabbitMQ's management UI on Windows to access attacker-controlled UNC paths, requiring multiple management plugins.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jul 2026
- **Updated:** 13 Jul 2026
- **Also known as:** AZL-92361, GHSA-7v84-m3g5-vxq6, UBUNTU-CVE-2026-57211

## What is CVE-2026-57211?

CVE-2026-57211 is a medium-severity server-side request forgery vulnerability in Broadcom Rabbitmq Server, published on 10 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

RabbitMQ is a messaging and streaming broker. Prior to 4.1.11 and 4.2.6 on Windows, the RabbitMQ management plugin static file handler rabbit_mgmt_wm_static can pass URL-encoded backslashes to erl_prim_loader:read_file_info before path validation when multiple management extension plugins are enabled, causing outbound DNS and SMB requests to attacker-controlled UNC paths. This issue is fixed in versions 4.1.11 and 4.2.6.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-36 (Absolute Path Traversal)

## Which versions are affected by CVE-2026-57211?

It affects 1 product.


Products: Broadcom Rabbitmq Server.

## How do I fix CVE-2026-57211?

Upgrade to a fixed version.

## Is CVE-2026-57211 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57211 exists.

## Other vulnerabilities in Broadcom Rabbitmq Server

- [CVE-2016-9877](https://insights.sbomify.com/CVE-2016-9877/): Auth bypass in Pivotal RabbitMQ 3.x before 3.5.8 and 3.6.x before 3.6.6; RabbitMQ for PCF 1.5.x before 1.5.20, 1.6.x before 1.6.12 and 1.7.x before 1.7.7 (critical 9.8)
- [CVE-2026-67404](https://insights.sbomify.com/CVE-2026-67404/): RabbitMQ: OAuth2 silent verify_none fallback for JWKS fetch (critical 9.2)
- [CVE-2026-67231](https://insights.sbomify.com/CVE-2026-67231/): RabbitMQ: Trust-store whitelist by Issuer+Serial only (critical 9.1)
- [CVE-2026-57219](https://insights.sbomify.com/CVE-2026-57219/): Information disclosure in rabbitmq-server (high 8.7)
- [CVE-2026-67236](https://insights.sbomify.com/CVE-2026-67236/): RabbitMQ: Plaintext username:password stored in an insecure cookie after successful POST /login (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57211 and fix it if it is affected.

What it is: CVE-2026-57211 is a medium-severity server-side request forgery vulnerability in Broadcom Rabbitmq Server, published on 10 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57211 exists.

Affected product: Broadcom Rabbitmq Server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57211/ (Markdown: https://insights.sbomify.com/CVE-2026-57211/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57211
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57211
- OSV: https://osv.dev/vulnerability/CVE-2026-57211

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57211/
Summaries are generated and may contain mistakes; the official description above is the record.
