CVE-2026-57212 RabbitMQ management HTTP API accepts request bodies larger than configured max_http_body_size

High 7.1 Published Updated

Attackers can cause denial of service by sending oversized JSON bodies to the RabbitMQ management HTTP API, bypassing configured size limits.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-57212?

CVE-2026-57212 is a high-severity denial of service vulnerability in Broadcom Rabbitmq Server, published on 10 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

RabbitMQ is a messaging and streaming broker. Prior to 3.13.14, 4.0.19, 4.1.10, and 4.2.5, the rabbitmq_management HTTP API accepts oversized valid JSON bodies on with_decode and direct_request paths because read_complete_body checks the accumulated size before the final chunk but not the final combined size. This issue is fixed in versions 3.13.14, 4.0.19, 4.1.10, and 4.2.5.

Weakness: CWE-770

Which versions are affected by CVE-2026-57212?

It affects 1 product.

Products include Broadcom Rabbitmq Server.

How do I fix CVE-2026-57212?

Upgrade to a fixed version.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-57212 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57212 exists.

All Broadcom Rabbitmq Server vulnerabilities

Sources

Also known as AZL-92358, DEBIAN-CVE-2026-57212, GHSA-5cmq-vp28-xqrj, UBUNTU-CVE-2026-57212.

Is CVE-2026-57212 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free