# CVE-2026-57212: RabbitMQ management HTTP API accepts request bodies larger than configured max_http_body_size

> Attackers can cause denial of service by sending oversized JSON bodies to the RabbitMQ management HTTP API, bypassing configured size limits.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jul 2026
- **Updated:** 13 Jul 2026
- **Also known as:** AZL-92358, DEBIAN-CVE-2026-57212, GHSA-5cmq-vp28-xqrj, UBUNTU-CVE-2026-57212

## What is CVE-2026-57212?

CVE-2026-57212 is a high-severity denial of service vulnerability in Broadcom Rabbitmq Server, published on 10 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

RabbitMQ is a messaging and streaming broker. Prior to 3.13.14, 4.0.19, 4.1.10, and 4.2.5, the rabbitmq_management HTTP API accepts oversized valid JSON bodies on with_decode and direct_request paths because read_complete_body checks the accumulated size before the final chunk but not the final combined size. This issue is fixed in versions 3.13.14, 4.0.19, 4.1.10, and 4.2.5.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-57212?

It affects 1 product.


Products: Broadcom Rabbitmq Server.

## How do I fix CVE-2026-57212?

Upgrade to a fixed version.

## Is CVE-2026-57212 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57212 exists.

## Other vulnerabilities in Broadcom Rabbitmq Server

- [CVE-2016-9877](https://insights.sbomify.com/CVE-2016-9877/): Auth bypass in Pivotal RabbitMQ 3.x before 3.5.8 and 3.6.x before 3.6.6; RabbitMQ for PCF 1.5.x before 1.5.20, 1.6.x before 1.6.12 and 1.7.x before 1.7.7 (critical 9.8)
- [CVE-2026-67404](https://insights.sbomify.com/CVE-2026-67404/): RabbitMQ: OAuth2 silent verify_none fallback for JWKS fetch (critical 9.2)
- [CVE-2026-67231](https://insights.sbomify.com/CVE-2026-67231/): RabbitMQ: Trust-store whitelist by Issuer+Serial only (critical 9.1)
- [CVE-2026-57219](https://insights.sbomify.com/CVE-2026-57219/): Information disclosure in rabbitmq-server (high 8.7)
- [CVE-2026-67236](https://insights.sbomify.com/CVE-2026-67236/): RabbitMQ: Plaintext username:password stored in an insecure cookie after successful POST /login (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57212 and fix it if it is affected.

What it is: CVE-2026-57212 is a high-severity denial of service vulnerability in Broadcom Rabbitmq Server, published on 10 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57212 exists.

Affected product: Broadcom Rabbitmq Server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57212/ (Markdown: https://insights.sbomify.com/CVE-2026-57212/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57212
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57212
- OSV: https://osv.dev/vulnerability/CVE-2026-57212

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57212/
Summaries are generated and may contain mistakes; the official description above is the record.
