# CVE-2026-57213: RabbitMQ: Stored XSS federation management plugin via unsanitized consumer_tag rendering

> An attacker with federation configuration privileges can inject JavaScript into the management UI, potentially hijacking sessions of administrators viewing the page.

- **Severity:** Medium 5.7 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:P/VC:H/VI:N/VA:N/SC:L/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Jul 2026
- **Updated:** 14 Jul 2026
- **Also known as:** AZL-92343, DEBIAN-CVE-2026-57213, GHSA-qxrp-7cmp-p77h, UBUNTU-CVE-2026-57213

## What is CVE-2026-57213?

CVE-2026-57213 is a medium-severity cross-site scripting vulnerability in Broadcom Rabbitmq Server, published on 10 Jul 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

RabbitMQ is a messaging and streaming broker. Prior to 3.13.14, 4.0.19, 4.1.10, and 4.2.5, the rabbitmq_federation_management plugin renders the consumer_tag field on the Federation Status page without HTML escaping, allowing a user who can configure a federation upstream or policy to execute JavaScript in the browser of a user viewing that page. This issue is fixed in versions 3.13.14, 4.0.19, 4.1.10, and 4.2.5.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-57213?

It affects 1 product.


Products: Broadcom Rabbitmq Server.

## How do I fix CVE-2026-57213?

Upgrade to a fixed version.

## Is CVE-2026-57213 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57213 exists.

## Other vulnerabilities in Broadcom Rabbitmq Server

- [CVE-2016-9877](https://insights.sbomify.com/CVE-2016-9877/): Auth bypass in Pivotal RabbitMQ 3.x before 3.5.8 and 3.6.x before 3.6.6; RabbitMQ for PCF 1.5.x before 1.5.20, 1.6.x before 1.6.12 and 1.7.x before 1.7.7 (critical 9.8)
- [CVE-2026-67404](https://insights.sbomify.com/CVE-2026-67404/): RabbitMQ: OAuth2 silent verify_none fallback for JWKS fetch (critical 9.2)
- [CVE-2026-67231](https://insights.sbomify.com/CVE-2026-67231/): RabbitMQ: Trust-store whitelist by Issuer+Serial only (critical 9.1)
- [CVE-2026-57219](https://insights.sbomify.com/CVE-2026-57219/): Information disclosure in rabbitmq-server (high 8.7)
- [CVE-2026-67236](https://insights.sbomify.com/CVE-2026-67236/): RabbitMQ: Plaintext username:password stored in an insecure cookie after successful POST /login (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57213 and fix it if it is affected.

What it is: CVE-2026-57213 is a medium-severity cross-site scripting vulnerability in Broadcom Rabbitmq Server, published on 10 Jul 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57213 exists.

Affected product: Broadcom Rabbitmq Server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57213/ (Markdown: https://insights.sbomify.com/CVE-2026-57213/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57213
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57213
- OSV: https://osv.dev/vulnerability/CVE-2026-57213

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57213/
Summaries are generated and may contain mistakes; the official description above is the record.
