# CVE-2026-57215: RabbitMQ: Direct-reply-to binding persistence can lead to unauthorized reply-channel injection and persistent phantom

> Attackers can inject unauthorized replies into direct-reply-to channels due to missing deletion checks, potentially intercepting sensitive data.

- **Severity:** High 7.0 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jul 2026
- **Updated:** 13 Jul 2026
- **Also known as:** AZL-92364, DEBIAN-CVE-2026-57215, GHSA-5cq3-v9jx-p3x3, UBUNTU-CVE-2026-57215, openSUSE-SU-2026:22163-1

## What is CVE-2026-57215?

CVE-2026-57215 is a high-severity missing authorization vulnerability in Broadcom Rabbitmq Server, published on 10 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

RabbitMQ is a messaging and streaming broker. Prior to 3.13.15, 4.0.20, 4.1.11, and 4.2.6, RabbitMQ allows foreign bindings to amq.rabbitmq.reply-to destinations because volatile direct-reply-to queues can be accepted at bind and route time but are missing from Khepri-backed deletion checks, leaving persistent route entries after unbind. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, and 4.2.6.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-57215?

It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rabbitmq-server` | openSUSE:Leap 16.0 | All versions | 4.1.5-160000.3.1 |

Products: Broadcom Rabbitmq Server.

## How do I fix CVE-2026-57215?

Upgrade to a fixed version.

## Is CVE-2026-57215 being exploited?

There is no known exploitation of CVE-2026-57215 in the wild and no public exploit code.

## Other vulnerabilities in Broadcom Rabbitmq Server

- [CVE-2016-9877](https://insights.sbomify.com/CVE-2016-9877/): Auth bypass in Pivotal RabbitMQ 3.x before 3.5.8 and 3.6.x before 3.6.6; RabbitMQ for PCF 1.5.x before 1.5.20, 1.6.x before 1.6.12 and 1.7.x before 1.7.7 (critical 9.8)
- [CVE-2026-67404](https://insights.sbomify.com/CVE-2026-67404/): RabbitMQ: OAuth2 silent verify_none fallback for JWKS fetch (critical 9.2)
- [CVE-2026-67231](https://insights.sbomify.com/CVE-2026-67231/): RabbitMQ: Trust-store whitelist by Issuer+Serial only (critical 9.1)
- [CVE-2026-57219](https://insights.sbomify.com/CVE-2026-57219/): Information disclosure in rabbitmq-server (high 8.7)
- [CVE-2026-67236](https://insights.sbomify.com/CVE-2026-67236/): RabbitMQ: Plaintext username:password stored in an insecure cookie after successful POST /login (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57215 and fix it if it is affected.

What it is: CVE-2026-57215 is a high-severity missing authorization vulnerability in Broadcom Rabbitmq Server, published on 10 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-57215 in the wild and no public exploit code.

Affected product: Broadcom Rabbitmq Server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57215/ (Markdown: https://insights.sbomify.com/CVE-2026-57215/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57215
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57215
- OSV: https://osv.dev/vulnerability/CVE-2026-57215

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57215/
Summaries are generated and may contain mistakes; the official description above is the record.
