CVE-2026-57216 Auth bypass in rabbitmq-server

Medium 6.8 Published Updated

Remote attackers can bypass loopback restrictions to connect as guest users via trusted proxy paths in RabbitMQ.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-57216?

CVE-2026-57216 is a medium-severity authentication bypass vulnerability in Broadcom Rabbitmq Server, published on 10 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

RabbitMQ is a messaging and streaming broker. Prior to 3.13.15, 4.0.20, 4.1.11, and 4.2.6, AMQP 0-9-1, AMQP 1.0, and Stream Protocol authentication can allow a loopback-restricted user such as guest to connect remotely when traffic is accepted through a trusted PROXY-protocol path and the backend listener is loopback-bound because the loopback check uses the listener-side socket address instead of the real client source. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, and 4.2.6.

Weakness: CWE-287

Which versions are affected by CVE-2026-57216?

It affects 1 product.

Products include Broadcom Rabbitmq Server.

How do I fix CVE-2026-57216?

Upgrade to a fixed version.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2026-57216 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57216 exists.

All Broadcom Rabbitmq Server vulnerabilities

Sources

Also known as AZL-92349, DEBIAN-CVE-2026-57216, GHSA-36m6-588r-vqcw, UBUNTU-CVE-2026-57216.

Is CVE-2026-57216 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free