CVE-2026-57217 RabbitMQ: Topic authorization can lead to cross-tenant routing-key bypass

High 7.0 Published Updated

Attackers can bypass topic authorization and perform restricted writes or binds during metadata-store failures in RabbitMQ.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-57217?

CVE-2026-57217 is a high-severity authentication bypass vulnerability in Broadcom Rabbitmq Server, published on 10 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

RabbitMQ is a messaging and streaming broker. Prior to 3.13.15, 4.0.21, 4.1.11, and 4.2.6, RabbitMQ topic authorization can allow restricted topic writes and binds during metadata-store failures because topic-permission lookup errors from Khepri can collapse to undefined, which the internal backend treats as allow. This issue is fixed in versions 3.13.15, 4.0.21, 4.1.11, and 4.2.6.

Weakness: CWE-863

Which versions are affected by CVE-2026-57217?

It affects 1 product.

Products include Broadcom Rabbitmq Server.

How do I fix CVE-2026-57217?

Upgrade to a fixed version.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2026-57217 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57217 exists.

All Broadcom Rabbitmq Server vulnerabilities

Sources

Also known as AZL-92340, DEBIAN-CVE-2026-57217, GHSA-gpvw-75h5-3wvx, UBUNTU-CVE-2026-57217.

Is CVE-2026-57217 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free