# CVE-2026-57231: Podman: Malformed Image can trick podman run into leaking host environment variables into the container

> A malicious container image can exfiltrate host environment variables into the container, exposing sensitive data to attackers.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Jun 2026
- **Updated:** 27 Jun 2026
- **Also known as:** AZL-91448, BELL-CVE-2026-57231, CLSA-2026-1784074201, DEBIAN-CVE-2026-57231, GHSA-4hq8-gpf5-8p68, GO-2026-6594, MINI-jxmx-4w4q-hmjq, MINI-wmcq-375g-6f5f, MINI-wxqm-894x-2xjq, UBUNTU-CVE-2026-57231, openSUSE-SU-2026:11437-1

## What is CVE-2026-57231?

CVE-2026-57231 is a high-severity vulnerability in podman-container-tools podman, published on 26 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Podman is a tool for managing OCI containers and pods. From 1.8.1 until 5.8.4, a container image that contains a environment variable with just a key and no value can trick podman into passing that variable from the host into the container. This is made worse by the fact that using an asterisk (*) will cause podman to pass all host variables into the container. So essentially a malicious image can exfiltrate all podman environment variables that are set in the session from where the container is launched. This vulnerability is fixed in 5.8.4 and 6.0.0.

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-57231?

19 open source packages ship an affected version, including github.com/containers/podman, github.com/containers/libpod and github.com/containers/podman/v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/containers/podman` | Go | All versions | None |
| `github.com/containers/podman` | Go | From 1.8.1 | None |
| `github.com/containers/podman` | Go | From 1.8.1 | None |
| `github.com/containers/libpod` | Go | From 1.8.1 | None |
| `github.com/containers/podman/v2` | Go | All versions | None |
| `github.com/containers/podman/v2` | Go | All versions to 2.2.1 | None |
| `github.com/containers/podman/v2` | Go | All versions to 2.2.1 | None |
| `github.com/containers/podman/v3` | Go | All versions | None |
| `github.com/containers/podman/v3` | Go | All versions to 3.4.7 | None |
| `github.com/containers/podman/v3` | Go | All versions to 3.4.7 | None |
| `github.com/containers/podman/v4` | Go | All versions | None |
| `github.com/containers/podman/v4` | Go | All versions to 4.9.5 | None |
| `github.com/containers/podman/v4` | Go | All versions to 4.9.5 | None |
| `github.com/containers/podman/v5` | Go | All versions | 5.8.4 |
| `github.com/containers/podman/v5` | Go | All versions | 5.8.4 |
| `github.com/containers/podman/v5` | Go | All versions | 5.8.4 |
| `go.podman.io/podman/v6` | Go | All versions | 6.0.0 |
| `go.podman.io/podman/v6` | Go | All versions | 6.0.0 |
| `go.podman.io/podman/v6` | Go | All versions | 6.0.0 |
| `podman` | openSUSE:Tumbleweed | All versions | 6.0.2-1.1 |

Products: Podman Project Podman.

## How do I fix CVE-2026-57231?

Upgrade to a fixed version.

## Is CVE-2026-57231 being exploited?

There is no known exploitation of CVE-2026-57231 in the wild and no public exploit code.

## Other vulnerabilities in podman-container-tools podman

- [CVE-2022-2738](https://insights.sbomify.com/CVE-2022-2738/): Use after free in podman (high 7.5)
- [CVE-2022-2989](https://insights.sbomify.com/CVE-2022-2989/): Podman's incorrect handling of the supplementary groups may lead to data disclosure, modification (high 7.1)
- [CVE-2021-20188](https://insights.sbomify.com/CVE-2021-20188/): Improper Authorization in github.com/containers/libpod (high 7.0)
- [CVE-2023-0778](https://insights.sbomify.com/CVE-2023-0778/): Podman Time-of-check Time-of-use (TOCTOU) Race Condition (medium 6.8)
- [CVE-2019-25067](https://insights.sbomify.com/CVE-2019-25067/): Podman/Varlink API Privilege Escalation (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57231 and fix it if it is affected.

What it is: CVE-2026-57231 is a high-severity vulnerability in podman-container-tools podman, published on 26 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-57231 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/containers/podman (Go): affected all versions; no fix listed
- github.com/containers/podman (Go): affected from 1.8.1; no fix listed
- github.com/containers/podman (Go): affected from 1.8.1; no fix listed
- github.com/containers/libpod (Go): affected from 1.8.1; no fix listed
- github.com/containers/podman/v2 (Go): affected all versions; no fix listed
- github.com/containers/podman/v2 (Go): affected all versions up to 2.2.1; no fix listed
- github.com/containers/podman/v2 (Go): affected all versions up to 2.2.1; no fix listed
- github.com/containers/podman/v3 (Go): affected all versions; no fix listed
- github.com/containers/podman/v3 (Go): affected all versions up to 3.4.7; no fix listed
- github.com/containers/podman/v3 (Go): affected all versions up to 3.4.7; no fix listed
- github.com/containers/podman/v4 (Go): affected all versions; no fix listed
- github.com/containers/podman/v4 (Go): affected all versions up to 4.9.5; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57231/ (Markdown: https://insights.sbomify.com/CVE-2026-57231/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57231
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57231
- OSV: https://osv.dev/vulnerability/CVE-2026-57231

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57231/
Summaries are generated and may contain mistakes; the official description above is the record.
