# CVE-2026-57232: Contao: Server-Side Request Forgery (SSRF) via Unvalidated RSS Feed URL in Feed Reader Module

> A backend user can exploit unvalidated RSS feed URLs to force the server to request internal network resources or cloud metadata endpoints.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Jul 2026
- **Updated:** 3 Aug 2026
- **Also known as:** GHSA-87mg-5grr-rhwh

## What is CVE-2026-57232?

CVE-2026-57232 is a low-severity server-side request forgery vulnerability in contao, published on 31 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Contao is an Open Source CMS. From 5.3.35 through 5.3.47 and from 5.7.0-RC1 through 5.7.8, the Feed Reader front-end module passes configured RSS feed URLs from FeedReaderController::getResponse() to feedIo->read() without scheme or private-address validation, allowing a backend user with module-edit permissions to make the server request internal network services, loopback addresses, or cloud metadata endpoints. In core-bundle/src/Controller/FrontendModule/FeedReaderController.php, the getResponse() function iterates over the configured feed URLs and passes each one directly to the HTTP client (via $this->feedIo->read($url, new Feed())) with no validation, while the DCA field definition for rss_feed in tl_module.php carries no URL scheme or host validation and the HTTP client is wired as @psr18.http_client (Symfony HttpClient) with no SSRF protection configured, since NoPrivateNetworkHttpClient is not used. This issue is fixed in versions 5.3.48.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-57232?

8 open source packages ship an affected version, including contao/contao and contao/core-bundle.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `contao/contao` | Packagist | From 5.3.35 | 5.3.48 |
| `contao/contao` | Packagist | From 5.3.35 | 5.3.48 |
| `contao/contao` | Packagist | From 5.4.0 | 5.7.9 |
| `contao/contao` | Packagist | From 5.4.0 | 5.7.9 |
| `contao/core-bundle` | Packagist | From 5.3.35 | 5.3.48 |
| `contao/core-bundle` | Packagist | From 5.3.35 | 5.3.48 |
| `contao/core-bundle` | Packagist | From 5.4.0 | 5.7.9 |
| `contao/core-bundle` | Packagist | From 5.4.0 | 5.7.9 |

## How do I fix CVE-2026-57232?

Upgrade contao/contao to a fixed version for your release line: 5.3.48 or 5.7.9.

## Is CVE-2026-57232 being exploited?

There is no known exploitation of CVE-2026-57232 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57232 and fix it if it is affected.

What it is: CVE-2026-57232 is a low-severity server-side request forgery vulnerability in contao, published on 31 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-57232 in the wild and no public exploit code.

Affected packages and fixed versions:
- contao/contao (Packagist): affected from 5.3.35; fixed in 5.3.48
- contao/contao (Packagist): affected from 5.3.35; fixed in 5.3.48
- contao/contao (Packagist): affected from 5.4.0; fixed in 5.7.9
- contao/contao (Packagist): affected from 5.4.0; fixed in 5.7.9
- contao/core-bundle (Packagist): affected from 5.3.35; fixed in 5.3.48
- contao/core-bundle (Packagist): affected from 5.3.35; fixed in 5.3.48
- contao/core-bundle (Packagist): affected from 5.4.0; fixed in 5.7.9
- contao/core-bundle (Packagist): affected from 5.4.0; fixed in 5.7.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57232/ (Markdown: https://insights.sbomify.com/CVE-2026-57232/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57232
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57232
- OSV: https://osv.dev/vulnerability/CVE-2026-57232

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57232/
Summaries are generated and may contain mistakes; the official description above is the record.
