# CVE-2026-57234: Nokogiri: XML::Schema on JRuby allows network requests when NONET is set, bypassing CVE-2020-26247

> An attacker can trigger network requests via XML Schema parsing on JRuby, bypassing security controls to enable SSRF or XXE attacks.

- **Severity:** Low 2.6 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Jun 2026
- **Updated:** 25 Jun 2026
- **Also known as:** AZL-91080, BELL-CVE-2026-57234, CLEANSTART-2026-EA82702, DEBIAN-CVE-2026-57234, GHSA-8678-w3jw-xfc2, MINI-7hcq-phpp-7mg8, MINI-94hg-9hqw-fprq, MINI-9qj8-p3g6-rh9f, MINI-jvqr-vfpp-prjh, MINI-mm4w-g7gr-p4rf, MINI-pg3g-88cw-ggqw, MINI-rf92-j4h4-fj72, MINI-vjp4-74j7-v26w, UBUNTU-CVE-2026-57234

## What is CVE-2026-57234?

CVE-2026-57234 is a low-severity vulnerability in sparklemotion nokogiri, published on 25 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Nokogiri is an open source XML and HTML library for the Ruby programming language. Prior to 1.19.4, the NONET parse option, which Nokogiri turns on by default for Nokogiri::XML::Schema (see CVE-2020-26247), was not correctly enforced on the JRuby implementation. As a result, a schema parsed with default options could still cause external resources to be fetched over the network, potentially enabling SSRF or XXE attacks. This vulnerability is fixed in 1.19.4.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference), CWE-184 (Incomplete List of Disallowed Inputs), CWE-178 (Improper Handling of Case Sensitivity)

## Which versions are affected by CVE-2026-57234?

2 open source packages ship an affected version, including nokogiri. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nokogiri` | RubyGems | All versions | 1.19.4 |
| `nokogiri` | RubyGems | All versions | 1.19.4 |

Products: Nokogiri Nokogiri.

## How do I fix CVE-2026-57234?

Upgrade nokogiri to 1.19.4 or later.

## Is CVE-2026-57234 being exploited?

There is no known exploitation of CVE-2026-57234 in the wild and no public exploit code.

## Other vulnerabilities in sparklemotion nokogiri

- [CVE-2026-79770](https://insights.sbomify.com/CVE-2026-79770/): Nokogiri before 1.19.3 ReDoS via CSS selector tokenizer (high 8.7)
- [CVE-2022-23476](https://insights.sbomify.com/CVE-2022-23476/): Unchecked return value from xmlTextReaderExpand in Nokogiri (high 7.5)
- [CVE-2021-41098](https://insights.sbomify.com/CVE-2021-41098/): Improper Restriction of XML External Entity Reference (XXE) in Nokogiri on JRuby (high 7.5)
- [CVE-2012-6685](https://insights.sbomify.com/CVE-2012-6685/): Nokogiri is vulnerable to XML External Entity (XXE) attack (high 7.5)
- [CVE-2026-79771](https://insights.sbomify.com/CVE-2026-79771/): Nokogiri before 1.19.3 Memory Leak via XSLT Transform (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57234 and fix it if it is affected.

What it is: CVE-2026-57234 is a low-severity vulnerability in sparklemotion nokogiri, published on 25 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-57234 in the wild and no public exploit code.

Affected packages and fixed versions:
- nokogiri (RubyGems): affected all versions; fixed in 1.19.4
- nokogiri (RubyGems): affected all versions; fixed in 1.19.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57234/ (Markdown: https://insights.sbomify.com/CVE-2026-57234/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57234
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57234
- OSV: https://osv.dev/vulnerability/CVE-2026-57234

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57234/
Summaries are generated and may contain mistakes; the official description above is the record.
