# CVE-2026-57236: Nokogiri: Possible Use-After-Free when `Nokogiri::XML::Document#encoding=` raises an exception

> Attackers can trigger a use-after-free in Nokogiri by passing invalid encodings, causing crashes or leaking memory in Ruby applications.

- **Severity:** Low 1.7 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Jun 2026
- **Updated:** 25 Jun 2026
- **Also known as:** AZL-91068, BELL-CVE-2026-57236, CLEANSTART-2026-TY62562, DEBIAN-CVE-2026-57236, GHSA-5v8h-3h3q-446p, MINI-6mm4-28v8-w62c, MINI-89vf-4mjr-pg87, MINI-c8gv-22hw-437g, MINI-cx96-rvg8-pwhf, MINI-m4v6-4835-6prj, MINI-m6jp-64c5-3428, MINI-q692-mcg4-hfq5, MINI-qmmv-x8rr-3rc7, UBUNTU-CVE-2026-57236

## What is CVE-2026-57236?

CVE-2026-57236 is a low-severity use after free vulnerability in sparklemotion nokogiri, published on 25 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Nokogiri is an open source XML and HTML library for the Ruby programming language. Prior to 1.19.4, calling Document#encoding= with an invalid encoding (e.g., a non-string, or a string containing a null byte) raises an exception, but only after freeing the document's current encoding string without replacing it. The document is left referencing freed memory, so the next call to Document#encoding reads invalid memory, which can cause a segfault or leak freed bytes into a Ruby String. Affects the CRuby (libxml2) implementation only; JRuby is not affected. This vulnerability is fixed in 1.19.4.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2026-57236?

2 open source packages ship an affected version, including nokogiri. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nokogiri` | RubyGems | All versions | 1.19.4 |
| `nokogiri` | RubyGems | All versions | 1.19.4 |

Products: Nokogiri Nokogiri.

## How do I fix CVE-2026-57236?

Upgrade nokogiri to 1.19.4 or later.

## Is CVE-2026-57236 being exploited?

There is no known exploitation of CVE-2026-57236 in the wild and no public exploit code.

## Other vulnerabilities in sparklemotion nokogiri

- [CVE-2026-79770](https://insights.sbomify.com/CVE-2026-79770/): Nokogiri before 1.19.3 ReDoS via CSS selector tokenizer (high 8.7)
- [CVE-2022-23476](https://insights.sbomify.com/CVE-2022-23476/): Unchecked return value from xmlTextReaderExpand in Nokogiri (high 7.5)
- [CVE-2021-41098](https://insights.sbomify.com/CVE-2021-41098/): Improper Restriction of XML External Entity Reference (XXE) in Nokogiri on JRuby (high 7.5)
- [CVE-2012-6685](https://insights.sbomify.com/CVE-2012-6685/): Nokogiri is vulnerable to XML External Entity (XXE) attack (high 7.5)
- [CVE-2026-79771](https://insights.sbomify.com/CVE-2026-79771/): Nokogiri before 1.19.3 Memory Leak via XSLT Transform (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57236 and fix it if it is affected.

What it is: CVE-2026-57236 is a low-severity use after free vulnerability in sparklemotion nokogiri, published on 25 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-57236 in the wild and no public exploit code.

Affected packages and fixed versions:
- nokogiri (RubyGems): affected all versions; fixed in 1.19.4
- nokogiri (RubyGems): affected all versions; fixed in 1.19.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57236/ (Markdown: https://insights.sbomify.com/CVE-2026-57236/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57236
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57236
- OSV: https://osv.dev/vulnerability/CVE-2026-57236

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57236/
Summaries are generated and may contain mistakes; the official description above is the record.
