# CVE-2026-57280: Jenkins Script Security Plugin sandbox bypass vulnerability

> Attackers can bypass the Groovy sandbox in Jenkins Script Security Plugin to invoke arbitrary constructors and execute code.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jun 2026
- **Updated:** 24 Jun 2026
- **Also known as:** GHSA-c3jm-9vj7-5v66, MINI-3f2f-qcqv-xg8r, MINI-937j-h7cg-733j, MINI-hj9x-xhvm-36f3, MINI-m66h-cv6m-fhrw, MINI-p5c5-x68v-cvxf, MINI-phg5-xrj5-pp72, MINI-xmvr-rhx8-mg49

## What is CVE-2026-57280?

CVE-2026-57280 is a high-severity vulnerability in Jenkins Script Security Plugin, published on 24 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins Script Security Plugin 1402.v94c9ce464861 and earlier does not intercept the implicit type casts applied to the elements of typed for-each loops in sandboxed Groovy scripts, allowing attackers able to provide such scripts to invoke arbitrary constructors and bypass the sandbox protection.

Weakness: CWE-693 (Protection Mechanism Failure)

## Which versions are affected by CVE-2026-57280?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:script-security. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:script-security` | Maven | All versions | 1402.1405.vc96e74964250 |
| `org.jenkins-ci.plugins:script-security` | Maven | All versions | 1402.1405.vc96e74964250 |

Products: Jenkins Script Security.

## How do I fix CVE-2026-57280?

Upgrade org.jenkins-ci.plugins:script-security to 1402.1405.vc96e74964250 or later.

## Is CVE-2026-57280 being exploited?

There is no known exploitation of CVE-2026-57280 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Script Security Plugin

- [CVE-2019-1003029](https://insights.sbomify.com/CVE-2019-1003029/): Jenkins Script Security Plugin Sandbox Bypass (critical 9.9, exploited in the wild)
- [CVE-2022-43401](https://insights.sbomify.com/CVE-2022-43401/): Sandbox bypass vulnerabilities in Jenkins Script Security Plugin and in Pipeline: Groovy Plugin (critical 9.9)
- [CVE-2022-43403](https://insights.sbomify.com/CVE-2022-43403/): Jenkins Script Security Plugin sandbox bypass vulnerability (critical 9.9)
- [CVE-2022-43404](https://insights.sbomify.com/CVE-2022-43404/): Sandbox bypass vulnerabilities in Jenkins Script Security Plugin and in Pipeline: Groovy Plugin (critical 9.9)
- [CVE-2020-2279](https://insights.sbomify.com/CVE-2020-2279/): Sandbox bypass vulnerability in Jenkins Script Security Plugin (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57280 and fix it if it is affected.

What it is: CVE-2026-57280 is a high-severity vulnerability in Jenkins Script Security Plugin, published on 24 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-57280 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:script-security (Maven): affected all versions; fixed in 1402.1405.vc96e74964250
- org.jenkins-ci.plugins:script-security (Maven): affected all versions; fixed in 1402.1405.vc96e74964250

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57280/ (Markdown: https://insights.sbomify.com/CVE-2026-57280/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57280
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57280
- OSV: https://osv.dev/vulnerability/CVE-2026-57280

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57280/
Summaries are generated and may contain mistakes; the official description above is the record.
