# CVE-2026-57281: Jenkins Script Security Plugin has a script security bypass vulnerability

> Attackers with sandboxed Groovy script execution rights can bypass the sandbox and execute arbitrary code on the Jenkins server.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jun 2026
- **Updated:** 7 Sep 2026
- **Also known as:** GHSA-cfj9-2vgr-hpxp, MINI-2fw6-9x52-mvc7, MINI-48wx-rj3g-c8xc, MINI-j287-wxhr-wgh2, MINI-j6jj-fm3m-2q3m, MINI-q23x-g3fj-8qfv, MINI-qmcv-qhjw-r27j, MINI-x5cc-pmwc-jg28

## What is CVE-2026-57281?

CVE-2026-57281 is a high-severity code injection vulnerability in Jenkins Script Security Plugin, published on 24 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins Script Security Plugin 1402.v94c9ce464861 and earlier does not reject Groovy AST transformation annotations carrying an extensions member, allowing attackers able to run sandboxed Groovy scripts to execute code outside the sandbox if a suitable script is present on the classpath of the component that evaluates the script.

Weakness: CWE-917 (Improper Neutralization of Special Elements used in an Expression Language Statement), CWE-93 (Improper Neutralization of CRLF Sequences), CWE-693 (Protection Mechanism Failure)

## Which versions are affected by CVE-2026-57281?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:script-security. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:script-security` | Maven | All versions | 1402.1405.vc96e74964250 |
| `org.jenkins-ci.plugins:script-security` | Maven | All versions | 1402.1405.vc96e74964250 |

Products: Jenkins Script Security.

## How do I fix CVE-2026-57281?

Upgrade org.jenkins-ci.plugins:script-security to 1402.1405.vc96e74964250 or later.

## Is CVE-2026-57281 being exploited?

There is no known exploitation of CVE-2026-57281 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Script Security Plugin

- [CVE-2019-1003029](https://insights.sbomify.com/CVE-2019-1003029/): Jenkins Script Security Plugin Sandbox Bypass (critical 9.9, exploited in the wild)
- [CVE-2022-43401](https://insights.sbomify.com/CVE-2022-43401/): Sandbox bypass vulnerabilities in Jenkins Script Security Plugin and in Pipeline: Groovy Plugin (critical 9.9)
- [CVE-2022-43403](https://insights.sbomify.com/CVE-2022-43403/): Jenkins Script Security Plugin sandbox bypass vulnerability (critical 9.9)
- [CVE-2022-43404](https://insights.sbomify.com/CVE-2022-43404/): Sandbox bypass vulnerabilities in Jenkins Script Security Plugin and in Pipeline: Groovy Plugin (critical 9.9)
- [CVE-2020-2279](https://insights.sbomify.com/CVE-2020-2279/): Sandbox bypass vulnerability in Jenkins Script Security Plugin (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57281 and fix it if it is affected.

What it is: CVE-2026-57281 is a high-severity code injection vulnerability in Jenkins Script Security Plugin, published on 24 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-57281 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:script-security (Maven): affected all versions; fixed in 1402.1405.vc96e74964250
- org.jenkins-ci.plugins:script-security (Maven): affected all versions; fixed in 1402.1405.vc96e74964250

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57281/ (Markdown: https://insights.sbomify.com/CVE-2026-57281/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57281
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57281
- OSV: https://osv.dev/vulnerability/CVE-2026-57281

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57281/
Summaries are generated and may contain mistakes; the official description above is the record.
