{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:PrioritySorter. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-57290 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:PrioritySorter to 936.937.v5581d0b or later.","what":"CVE-2026-57290 is a medium-severity vulnerability in Jenkins Priority Sorter Plugin, published on 24 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-57290 and fix it if it is affected.\n\nWhat it is: CVE-2026-57290 is a medium-severity vulnerability in Jenkins Priority Sorter Plugin, published on 24 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-57290 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:PrioritySorter (Maven): affected all versions; fixed in 936.937.v5581d0b\n- org.jenkins-ci.plugins:PrioritySorter (Maven): affected all versions; fixed in 936.937.v5581d0b\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-57290/ (Markdown: https://insights.sbomify.com/CVE-2026-57290/index.md)","id":"CVE-2026-57290","markdown":"https://insights.sbomify.com/CVE-2026-57290/index.md","name":"CVE-2026-57290","record":{"aliases":["GHSA-fq56-wvv2-p8jf"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Priority Sorter Plugin","requires_auth":"none","summary":"Attackers can overwrite global job priority configuration via CSRF, requiring Jenkins administrators to update the Priority Sorter Plugin.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"priority_sorter","vendor":"jenkins"}],"cvss":{"score":4.3,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"A cross-site request forgery (CSRF) vulnerability in Jenkins Priority Sorter Plugin 936.v2c01c6b_84449 and earlier allows attackers to overwrite the global job priority configuration.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Priority Sorter Plugin has a CSRF vulnerability","id":"CVE-2026-57290","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"csrf","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"Jenkins Gitee Plugin missing permission checks","id":"CVE-2026-57291"},"packages":[{"ecosystem":"Maven","fixed":["936.937.v5581d0b"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:PrioritySorter","purl":null,"source":"GHSA-fq56-wvv2-p8jf"},{"ecosystem":"Maven","fixed":["936.937.v5581d0b"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:PrioritySorter","purl":"pkg:maven/org.jenkins-ci.plugins/PrioritySorter","source":"GHSA-fq56-wvv2-p8jf"}],"prev":{"headline":"Jenkins Bitbucket Push and Pull Request Plugin unconditionally disables SSL/TLS certificate validation","id":"CVE-2026-57289"},"products":["Jenkins Priority Sorter Plugin"],"published":"2026-06-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-24","vendors":["Jenkins Project"]},"summary":"Attackers can overwrite global job priority configuration via CSRF, requiring Jenkins administrators to update the Priority Sorter Plugin.","url":"https://insights.sbomify.com/CVE-2026-57290/"}