# CVE-2026-57290: Jenkins Priority Sorter Plugin has a CSRF vulnerability

> Attackers can overwrite global job priority configuration via CSRF, requiring Jenkins administrators to update the Priority Sorter Plugin.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Jun 2026
- **Updated:** 24 Jun 2026
- **Also known as:** GHSA-fq56-wvv2-p8jf

## What is CVE-2026-57290?

CVE-2026-57290 is a medium-severity vulnerability in Jenkins Priority Sorter Plugin, published on 24 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A cross-site request forgery (CSRF) vulnerability in Jenkins Priority Sorter Plugin 936.v2c01c6b_84449 and earlier allows attackers to overwrite the global job priority configuration.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2026-57290?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:PrioritySorter. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:PrioritySorter` | Maven | All versions | 936.937.v5581d0b |
| `org.jenkins-ci.plugins:PrioritySorter` | Maven | All versions | 936.937.v5581d0b |

Products: Jenkins Priority Sorter.

## How do I fix CVE-2026-57290?

Upgrade org.jenkins-ci.plugins:PrioritySorter to 936.937.v5581d0b or later.

## Is CVE-2026-57290 being exploited?

There is no known exploitation of CVE-2026-57290 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57290 and fix it if it is affected.

What it is: CVE-2026-57290 is a medium-severity vulnerability in Jenkins Priority Sorter Plugin, published on 24 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-57290 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:PrioritySorter (Maven): affected all versions; fixed in 936.937.v5581d0b
- org.jenkins-ci.plugins:PrioritySorter (Maven): affected all versions; fixed in 936.937.v5581d0b

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57290/ (Markdown: https://insights.sbomify.com/CVE-2026-57290/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57290
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57290
- OSV: https://osv.dev/vulnerability/CVE-2026-57290

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57290/
Summaries are generated and may contain mistakes; the official description above is the record.
