# CVE-2026-57300: Jenkins MCP Server Plugin missing a permission check

> Attackers with Item/Read permission can read Pipeline replay scripts of accessible jobs due to a missing permission check in the Jenkins MCP Server Plugin.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jun 2026
- **Updated:** 24 Jun 2026
- **Also known as:** GHSA-mpff-xhg4-vr45

## What is CVE-2026-57300?

CVE-2026-57300 is a medium-severity missing authorization vulnerability in Jenkins MCP Server Plugin, published on 24 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A missing permission check in Jenkins MCP Server Plugin 0.177.v629fdb_2557fe and earlier allows attackers with Item/Read permission to read the Pipeline replay scripts of jobs they can access.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-57300?

2 open source packages ship an affected version, including io.jenkins.plugins:mcp-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.jenkins.plugins:mcp-server` | Maven | All versions | 0.178.vffe5a |
| `io.jenkins.plugins:mcp-server` | Maven | All versions | 0.178.vffe5a |

Products: Jenkins Mcp Server.

## How do I fix CVE-2026-57300?

Upgrade io.jenkins.plugins:mcp-server to 0.178.vffe5a or later.

## Is CVE-2026-57300 being exploited?

There is no known exploitation of CVE-2026-57300 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins MCP Server Plugin

- [CVE-2025-64132](https://insights.sbomify.com/CVE-2025-64132/): Jenkins MCP Server Plugin does not perform permission checks in multiple MCP tools (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57300 and fix it if it is affected.

What it is: CVE-2026-57300 is a medium-severity missing authorization vulnerability in Jenkins MCP Server Plugin, published on 24 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-57300 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.jenkins.plugins:mcp-server (Maven): affected all versions; fixed in 0.178.vffe5a
- io.jenkins.plugins:mcp-server (Maven): affected all versions; fixed in 0.178.vffe5a

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57300/ (Markdown: https://insights.sbomify.com/CVE-2026-57300/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57300
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57300
- OSV: https://osv.dev/vulnerability/CVE-2026-57300

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57300/
Summaries are generated and may contain mistakes; the official description above is the record.
