CVE-2026-57308 Apache Syncope: SQL injection vulnerability in Audit Events search

Critical 9.8 Published Updated

Administrators can execute arbitrary SQL via unsanitized sort parameters in Audit Events search, allowing data access or modification.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-57308?

CVE-2026-57308 is a critical SQL injection vulnerability in Apache Syncope, published on 20 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Syncope.

An administrator with adequate entitlements can achieve execution of arbitrary SQL via stacked queries, leveraging unsanitized sort parameters.

This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 Through 4.0.6, from 4.1.0-M0 through 4.1.1.

Users are recommended to upgrade to version 4.0.7 / 4.1.2, which fix this issue.

Weakness: CWE-89

Which versions are affected by CVE-2026-57308?

It affects 1 product.

Products include Apache Syncope.

How do I fix CVE-2026-57308?

No fix has been published for CVE-2026-57308 yet. Limit exposure of the affected software until one is available.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2026-57308 being exploited?

There is no known exploitation of CVE-2026-57308 in the wild and no public exploit code.

Sources

Also known as GHSA-vqgw-p6qv-w77q.

Is CVE-2026-57308 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free