CVE-2026-5740 Unauthenticated WebSocket binary frame causes denial of service in Mattermost Server
Unauthenticated attackers can crash the Mattermost server by sending crafted WebSocket messages, causing a full service outage.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-5740?
CVE-2026-5740 is a high-severity denial of service vulnerability in Mattermost Mattermost Server, published on 22 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Mattermost versions 11.6.x <= 11.6.0, 11.5.x <= 11.5.3, 11.4.x <= 11.4.4, 10.11.x <= 10.11.14 fail to properly validate msgpack-encoded WebSocket frames before memory allocation which allows an unauthenticated remote attacker to crash the server process and cause a full service outage for all users via a crafted binary WebSocket message sent to the public WebSocket endpoint.. Mattermost Advisory ID: MMSA-2026-00647
Weakness: CWE-789
Which versions are affected by CVE-2026-5740?
14 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.15 |
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.15 |
github.com/mattermost/mattermost-server Go | From 10.11.0+incompatible | 10.11.15+incompatible, 11.4.5+incompatible, 11.5.4+incompatible, 11.6.1+incompatible |
github.com/mattermost/mattermost-server Go | From 11.4.0 | 11.4.5 |
github.com/mattermost/mattermost-server Go | From 11.4.0 | 11.4.5 |
github.com/mattermost/mattermost-server Go | From 11.5.0 | 11.5.4 |
8 more packages
github.com/mattermost/mattermost-server Go | From 11.5.0 | 11.5.4 |
github.com/mattermost/mattermost-server Go | From 11.6.0 | 11.6.1 |
github.com/mattermost/mattermost-server Go | From 11.6.0 | 11.6.1 |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20260410202636-17939826efa2 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20260410202636-17939826efa2 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20260410202636-17939826efa2 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2026-5740?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.11.15, 10.11.15+incompatible, 11.4.5+incompatible or 11.5.4+incompatible.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-5740 being exploited?
There is no known exploitation of CVE-2026-5740 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-w9m8-p4cc-4qj9, GO-2026-5838.