# CVE-2026-57437: Nokogiri: Possible Use-After-Free when directly using `NokogirI::XML::XPathContext` beyond document lifetime

> Developers using Nokogiri's XPathContext directly may experience crashes if the underlying document is garbage collected before the context is used.

- **Severity:** Low 1.7 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:U/U:Clear`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Jun 2026
- **Updated:** 25 Jun 2026
- **Also known as:** AZL-91071, BELL-CVE-2026-57437, CLEANSTART-2026-VA15262, DEBIAN-CVE-2026-57437, GHSA-p67v-3w7g-wjg7, MINI-78h9-g9x6-6f2x, MINI-7vvv-wqvv-jwwg, MINI-89pg-876c-6prj, MINI-h9cx-hpwx-r3fw, MINI-hf73-g2gp-rf5j, MINI-m95q-jx8m-qf8c, MINI-mr35-63c8-mh6m, MINI-mvjm-xpmg-6c8q, UBUNTU-CVE-2026-57437

## What is CVE-2026-57437?

CVE-2026-57437 is a low-severity use after free vulnerability in sparklemotion nokogiri, published on 25 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Nokogiri is an open source XML and HTML library for the Ruby programming language. Prior to 1.19.4, Nokogiri::XML::XPathContext did not keep its source document alive for garbage collection. If an XPathContext outlived its document and the document was collected, evaluating an XPath expression could read invalid memory and potentially segfault. This is only reachable when application code constructs an XPathContext directly and lets the document become unreachable while continuing to use the context. The normal Document#xpath, #css, and related search methods are not affected, and it is not triggerable by malicious document input. This vulnerability is fixed in 1.19.4.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2026-57437?

2 open source packages ship an affected version, including nokogiri. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nokogiri` | RubyGems | All versions | 1.19.4 |
| `nokogiri` | RubyGems | All versions | 1.19.4 |

Products: Nokogiri Nokogiri.

## How do I fix CVE-2026-57437?

Upgrade nokogiri to 1.19.4 or later.

## Is CVE-2026-57437 being exploited?

There is no known exploitation of CVE-2026-57437 in the wild and no public exploit code.

## Other vulnerabilities in sparklemotion nokogiri

- [CVE-2026-79770](https://insights.sbomify.com/CVE-2026-79770/): Nokogiri before 1.19.3 ReDoS via CSS selector tokenizer (high 8.7)
- [CVE-2022-23476](https://insights.sbomify.com/CVE-2022-23476/): Unchecked return value from xmlTextReaderExpand in Nokogiri (high 7.5)
- [CVE-2021-41098](https://insights.sbomify.com/CVE-2021-41098/): Improper Restriction of XML External Entity Reference (XXE) in Nokogiri on JRuby (high 7.5)
- [CVE-2012-6685](https://insights.sbomify.com/CVE-2012-6685/): Nokogiri is vulnerable to XML External Entity (XXE) attack (high 7.5)
- [CVE-2026-79771](https://insights.sbomify.com/CVE-2026-79771/): Nokogiri before 1.19.3 Memory Leak via XSLT Transform (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57437 and fix it if it is affected.

What it is: CVE-2026-57437 is a low-severity use after free vulnerability in sparklemotion nokogiri, published on 25 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-57437 in the wild and no public exploit code.

Affected packages and fixed versions:
- nokogiri (RubyGems): affected all versions; fixed in 1.19.4
- nokogiri (RubyGems): affected all versions; fixed in 1.19.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57437/ (Markdown: https://insights.sbomify.com/CVE-2026-57437/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57437
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57437
- OSV: https://osv.dev/vulnerability/CVE-2026-57437

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57437/
Summaries are generated and may contain mistakes; the official description above is the record.
