# CVE-2026-57438: Nokogiri: Possible Use-After-Free in XInclude Processing

> An attacker can trigger a use-after-free in Nokogiri's XInclude processing, potentially leading to memory corruption or crashes.

- **Severity:** Low 2.2 (`CVSS:4.0/AV:L/AC:H/AT:N/PR:N/UI:N/VC:L/VI:L/VA:H/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Jun 2026
- **Updated:** 25 Jun 2026
- **Also known as:** AZL-91062, BELL-CVE-2026-57438, CLEANSTART-2026-EZ51982, DEBIAN-CVE-2026-57438, GHSA-wfpw-mmfh-qq69, MINI-526p-87jf-54cp, MINI-977m-6v47-hx9g, MINI-g966-3985-6p2m, MINI-h984-v6cq-vmm2, MINI-jccg-j7rf-xcfg, MINI-mqqc-g5pg-8frq, MINI-rmp5-c5xp-mgxj, MINI-vqqh-mw23-jccw, UBUNTU-CVE-2026-57438

## What is CVE-2026-57438?

CVE-2026-57438 is a low-severity use after free vulnerability in sparklemotion nokogiri, published on 25 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Nokogiri is an open source XML and HTML library for the Ruby programming language. Prior to 1.19.4, XInclude substitution performed by Nokogiri::XML::Node#do_xinclude replaced each <xi:include> in place, freeing the include node along with its children (such as <xi:fallback> and its descendants) and any namespaces declared on them. If an application had already exposed one of those nodes or namespaces to Ruby, the corresponding Ruby object was left pointing at freed memory. Using the object could result in invalid reads or writes to memory. This vulnerability is fixed in 1.19.4.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2026-57438?

2 open source packages ship an affected version, including nokogiri. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nokogiri` | RubyGems | All versions | 1.19.4 |
| `nokogiri` | RubyGems | All versions | 1.19.4 |

Products: Nokogiri Nokogiri.

## How do I fix CVE-2026-57438?

Upgrade nokogiri to 1.19.4 or later.

## Is CVE-2026-57438 being exploited?

There is no known exploitation of CVE-2026-57438 in the wild and no public exploit code.

## Other vulnerabilities in sparklemotion nokogiri

- [CVE-2026-79770](https://insights.sbomify.com/CVE-2026-79770/): Nokogiri before 1.19.3 ReDoS via CSS selector tokenizer (high 8.7)
- [CVE-2022-23476](https://insights.sbomify.com/CVE-2022-23476/): Unchecked return value from xmlTextReaderExpand in Nokogiri (high 7.5)
- [CVE-2021-41098](https://insights.sbomify.com/CVE-2021-41098/): Improper Restriction of XML External Entity Reference (XXE) in Nokogiri on JRuby (high 7.5)
- [CVE-2012-6685](https://insights.sbomify.com/CVE-2012-6685/): Nokogiri is vulnerable to XML External Entity (XXE) attack (high 7.5)
- [CVE-2026-79771](https://insights.sbomify.com/CVE-2026-79771/): Nokogiri before 1.19.3 Memory Leak via XSLT Transform (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57438 and fix it if it is affected.

What it is: CVE-2026-57438 is a low-severity use after free vulnerability in sparklemotion nokogiri, published on 25 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-57438 in the wild and no public exploit code.

Affected packages and fixed versions:
- nokogiri (RubyGems): affected all versions; fixed in 1.19.4
- nokogiri (RubyGems): affected all versions; fixed in 1.19.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57438/ (Markdown: https://insights.sbomify.com/CVE-2026-57438/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57438
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57438
- OSV: https://osv.dev/vulnerability/CVE-2026-57438

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57438/
Summaries are generated and may contain mistakes; the official description above is the record.
