# CVE-2026-57458: Vikunja: Scoped API token can mint unrestricted OAuth session credentials

> Attackers with scoped API tokens can mint unrestricted OAuth credentials, bypassing permission limits to access unauthorized data in Vikunja.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Oct 2026
- **Updated:** 13 Oct 2026
- **Also known as:** GHSA-v3p6-34mc-hj7v, GO-2026-6750

## What is CVE-2026-57458?

CVE-2026-57458 is a high-severity vulnerability in go-vikunja vikunja, published on 9 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Vikunja is an open-source self-hosted task management platform. In version 2.3.0, a scoped API token limited to the `oauth.authorize` permission can call `POST /api/v1/oauth/authorize`, obtain an OAuth authorization code, and exchange the code at `POST /api/v1/oauth/token` for a normal bearer JSON Web Token (JWT) and refresh token. The resulting credentials are not restricted by the original API token's permissions, allowing access to routes outside its declared scope for the same user. Version 2.4.0 fixes the vulnerability.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2026-57458?

3 open source packages ship an affected version, including code.vikunja.io/api.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `code.vikunja.io/api` | Go | All versions | None |
| `code.vikunja.io/api` | Go | From 2.3.0 | 2.4.0 |
| `code.vikunja.io/api` | Go | From 2.3.0 | 2.4.0 |

## How do I fix CVE-2026-57458?

Upgrade code.vikunja.io/api to 2.4.0 or later.

## Is CVE-2026-57458 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57458 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57458 and fix it if it is affected.

What it is: CVE-2026-57458 is a high-severity vulnerability in go-vikunja vikunja, published on 9 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57458 exists.

Affected packages and fixed versions:
- code.vikunja.io/api (Go): affected all versions; no fix listed
- code.vikunja.io/api (Go): affected from 2.3.0; fixed in 2.4.0
- code.vikunja.io/api (Go): affected from 2.3.0; fixed in 2.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57458/ (Markdown: https://insights.sbomify.com/CVE-2026-57458/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57458
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57458
- OSV: https://osv.dev/vulnerability/CVE-2026-57458

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57458/
Summaries are generated and may contain mistakes; the official description above is the record.
