CVE-2026-5747 Out-of-bounds Write in Firecracker virtio-pci Transport
A local guest user can trigger an out-of-bounds write in Firecracker, potentially crashing the VMM or executing code on the host under specific configurations.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-5747?
CVE-2026-5747 is a high-severity memory corruption vulnerability in AWS Firecracker, published on 7 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
An out-of-bounds write issue in the virtio PCI transport in Firecracker 1.13.0 through 1.14.3 and 1.15.0 on x86_64 and aarch64 might allow a local guest user with root privileges to crash the Firecracker VMM process or potentially execute arbitrary code on the host via modification of virtio queue configuration registers after device activation. Achieving code execution on the host requires additional preconditions, such as the use of a custom guest kernel or specific snapshot configurations.
To remediate this, users should upgrade to Firecracker 1.14.4 or 1.15.1 and later.
Which versions are affected by CVE-2026-5747?
It affects 1 product.
Linux distribution packages (1)
firecracker openSUSE:Tumbleweed | All versions | 1.15.1-1.1 |
Products include Amazon Firecracker.
How do I fix CVE-2026-5747?
Upgrade to a fixed version.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2026-5747 being exploited?
There is no known exploitation of CVE-2026-5747 in the wild and no public exploit code.
Other vulnerabilities in AWS Firecracker
Sources
Also known as GHSA-776c-mpj7-jm3r, openSUSE-SU-2026:10561-1.